Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Где я делаю ошибку?

Сова
Пост №1
Сова
читатель
офлайн
Дата регистрации: 31.10.2002
Сообщений: 42
Пост №1
 
03.02.2003 15:52

"Процедура Сформировать()

Спр = СоздатьОбъект("Справочник.Сотрудники");

Периодический = СоздатьОбъект("Периодический");

мдСправочник = Метаданные.Справочник("Сотрудники");

Спр.ВыбратьЭлементы();

Пока Спр.ПолучитьЭлемент()=1 Цикл

Для Сч = 1 По мдСправочник.Реквизит() Цикл

      ВидемыйДокумент=0;

      Реквизит = Метаданные.Справочник("Сотрудники").Реквизит(Сч);

      Если Спр.ЭтоГруппа()=0 Тогда

       Если Реквизит.Периодический = 1 Тогда

       Периодический.ИспользоватьОбъект(Реквизит);

       Периодический.ВыбратьЗначения();

       Пока Периодический.ПолучитьЗначение() = 1 Цикл

            Периодический.Удалить();

       КонецЦикла;

       КонецЕсли;

      КонецЕсли;

КонецЦикла;

КонецЦикла;

КонецПроцедуры

ОШИБКА!!!

Периодический.ИспользоватьОбъект(Реквизит);

не является константой или периодическим параметром!

На самом деле Допустим Поле ОКЛАД я вляется периодическим?"

Tanto
Пост №2
Tanto
читатель
офлайн
Дата регистрации: 14.10.2002
Сообщений: 19
Пост №2
 
03.02.2003 17:02

"Периодический.ИспользоватьОбъект(Реквизит,Спр);

"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.