Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Где я делаю ошибку?

Сова
читатель
офлайн
Дата регистрации: 31.10.2002
Сообщений: 42
Пост №1
 
03.02.2003 15:52

"Процедура Сформировать()<br><br> Спр = СоздатьОбъект("Справочник.Сотрудники");<br><br> Периодический = СоздатьОбъект("Периодический");<br><br> мдСправочник = Метаданные.Справочник("Сотрудники");<br><br> Спр.ВыбратьЭлементы();<br><br> Пока Спр.ПолучитьЭлемент()=1 Цикл<br><br> Для Сч = 1 По мдСправочник.Реквизит() Цикл<br><br>      ВидемыйДокумент=0;<br><br>      Реквизит = Метаданные.Справочник("Сотрудники").Реквизит(Сч);<br><br>      Если Спр.ЭтоГруппа()=0 Тогда<br><br>       Если Реквизит.Периодический = 1 Тогда<br><br>       Периодический.ИспользоватьОбъект(Реквизит);<br><br>       Периодический.ВыбратьЗначения();<br><br>       Пока Периодический.ПолучитьЗначение() = 1 Цикл<br><br>            Периодический.Удалить();<br><br>       КонецЦикла;<br><br>       КонецЕсли;<br><br>      КонецЕсли;<br><br> КонецЦикла;<br><br> КонецЦикла;<br><br>КонецПроцедуры<br><br>ОШИБКА!!!<br><br>Периодический.ИспользоватьОбъект(Реквизит);<br><br>не является константой или периодическим параметром!<br><br>На самом деле Допустим Поле ОКЛАД я вляется периодическим?"

Tanto
читатель
офлайн
Дата регистрации: 14.10.2002
Сообщений: 19
Пост №2
 
03.02.2003 17:02

"Периодический.ИспользоватьОбъект(Реквизит,Спр); <br><br>"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 19 октября 2021 года (вторник, начало в 12:00, все желающие)Маркировка лекарственных средств на примере "1С:Управление аптечной сетью" и "ОКСи:Рабочее место кассира"

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С