Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Почему не грузиться в 1с новый производитель с тем же артикулом? Как изменить обработку что-бы артикул не проверялся а сразу заводился в справочник?

сергей петров
читатель
офлайн
Дата регистрации: 20.11.2018
Сообщений: 37
Пост №1
 
22.01.2019 17:13

Почему не грузиться в 1с новый производитель с тем же артикулом? Как изменить обработку что-бы артикул не проверялся а сразу заводился в справочник?

&НаСервере
Функция ПолучитьНоменклатуру(СтрокаТекст)
      
      Запрос = Новый Запрос;
      Артикул = СтрокаТекст.Артикул;
      Наименование = СтрокаТекст.Наименование;
      
      Запрос.УстановитьПараметр("Артикул", Артикул);
      Запрос.Текст = "ВЫБРАТЬ
       |      Номенклатура.Ссылка
       |ИЗ
       |      Справочник.Номенклатура КАК Номенклатура
       |ГДЕ
       |      Номенклатура.Артикул = &Артикул
       |      И НЕ Номенклатура.ПометкаУдаления";
      
      Выборка = Запрос.Выполнить().Выбрать();
      
      Если Выборка.Следующий() тогда
            
            НоменклатураСсылка = Выборка.Ссылка;
            
      Иначе      
            
            РодительСсылка = ГруппаНоменклатуры;
            
            // Производитель
            ТекстПроизводитель = СокрЛП(СтрокаТекст.Производитель);
            Если ЗначениеЗаполнено(ТекстПроизводитель) тогда
                  Запрос = Новый Запрос;
                  Запрос.УстановитьПараметр("Наименование",      ТекстПроизводитель);
                  Запрос.УстановитьПараметр("Владелец",             ХарактеристикаПроизводитель);
                  Запрос.Текст = "ВЫБРАТЬ
                   |      ЗначенияСвойствОбъектов.Ссылка
                   |ИЗ
                   |      Справочник.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
                   |ГДЕ
                   |      ЗначенияСвойствОбъектов.Наименование = &Наименование
                   |      И ЗначенияСвойствОбъектов.Владелец = &Владелец";
                  
                  ВыборкаПроизводитель = Запрос.Выполнить().Выбрать();
                  Если ВыборкаПроизводитель.Следующий() тогда
                        ПроизводительСсылка = ВыборкаПроизводитель.Ссылка;
                  Иначе
                        ПроизводительОбъект = Справочники.ЗначенияСвойствОбъектов.СоздатьЭлемент();
                        ПроизводительОбъект.Владелец = ХарактеристикаПроизводитель;
                        ПроизводительОбъект.Наименование = ТекстПроизводитель;
                        Попытка
                              ПроизводительОбъект.Записать();
                        Исключение
                              Сообщить(ОписаниеОшибки());
                        КонецПопытки;      
                        ПроизводительСсылка = ПроизводительОбъект.Ссылка;
                  КонецЕсли;
            Иначе
                  ПроизводительСсылка = Справочники.ЗначенияСвойствОбъектов.ПустаяСсылка();
            КонецЕсли;      
                  
            НоменклатураОбъект = Справочники.Номенклатура.СоздатьЭлемент();
            НоменклатураОбъект.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
            НоменклатураОбъект.ВидНоменклатуры = ВидНоменклатуры;
            НоменклатураОбъект.Качество = Перечисления.ГрадацииКачества.Новый;
            НоменклатураОбъект.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
            
            ЗаполнитьЗначенияСвойств(НоменклатураОбъект, ВидНоменклатуры, , "Ссылка, Владелец, ПометкаУдаления, ВерсияДанных, Предопределенный, ЭтоГруппа, Родитель, Описание, Наименование, Код, ИмяПредопределенныхДанных");
            
            Если ИспользоватьУпаковки тогда
                  НоменклатураОбъект.ИспользоватьУпаковки = ИспользоватьУпаковки;
                  НоменклатураОбъект.НаборУпаковок = НаборУпаковок;
                  НоменклатураОбъект.ЕдиницаИзмерения = НаборУпаковок.ЕдиницаИзмерения;
            КонецЕсли;      
            
            ГруппаДоступаНоменклатурыДляКонтроля = ВидНоменклатуры.ГруппаДоступа;
            ШаблонНаименованияДляПечати = ВидНоменклатуры.ШаблонНаименованияДляПечатиНоменклатуры;
            ШаблонРабочегоНаименования = ВидНоменклатуры.ШаблонРабочегоНаименованияНоменклатуры;
            ЗапретРедактированияНаименованияДляПечати = ВидНоменклатуры.ЗапретРедактированияНаименованияНоменклатурыДляПечати;
            ЗапретРедактированияРабочегоНаименования = ВидНоменклатуры.ЗапретРедактированияРабочегоНаименованияНоменклатуры;
            НаборСвойств = ВидНоменклатуры.НаборСвойств;
            ИспользоватьХарактеристики = ВидНоменклатуры.ИспользоватьХарактеристики;
            ЭтоНабор = Ложь;
            ВидСодержитДрагоценныеМатериалы = Ложь;
            
            НоменклатураОбъект.Наименование = Наименование;
            НоменклатураОбъект.НаименованиеПолное = Наименование;
            НоменклатураОбъект.Артикул = Артикул;
            НоменклатураОбъект.Родитель = РодительСсылка;
            
            ЗаписьПроизводитель = НоменклатураОбъект.ДополнительныеРеквизиты.Добавить();
            ЗаписьПроизводитель.Значение = ПроизводительСсылка;
            ЗаписьПроизводитель.Свойство = ХарактеристикаПроизводитель;
            
            Попытка
                  НоменклатураОбъект.Записать();
            Исключение
                  Сообщить(ОписаниеОшибки());
            КонецПопытки;      
            НоменклатураСсылка = НоменклатураОбъект.Ссылка;
                              
      КонецЕсли;      
      
      Возврат НоменклатураСсылка;
      
КонецФункции

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

16 декабря 2020 годаЕдиный онлайн-семинар 1С для бухгалтеров и руководителей

1C:Лекторий: 8 декабря 2020 года (вторник, начало в 12:00, все желающие)Создание новых видов начислений и видов времени в 1С:ЗУП, редакция 3

1C:Лекторий: 9 декабря 2020 года (среда, начало в 12:00, все желающие)Как снизить рекламный бюджет и увеличить эффективность рекламы с помощью 1С:Маркетинг.Лидогенерация

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С