Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

Ошибки в 1с:Бухгалтерия 7.7 релиз 657

Guest_2020
читатель
офлайн
Дата регистрации: 06.05.2020
Сообщений: 9
Пост №1
 
12.06.2020 10:38

Просто нет цензурных слов! Ошибка воспроизводится на типовом релизе.
Релиз бухгалтерии №657, с апреля 2020 установлен тариф страховых взносов "Для субъектов малого и среднего..."
Сотруднику начислена ЗП за апрель 200 000, двумя документами по 100 000, с разными проводками БУ,
Счет=26, Субконто1= "Зарплата", Субконто2="Основное подразделение"
И
Счет=26, Субконто1= "Зарплата", Субконто2="АУП"
то есть отличается только одно субконто, статья затрат для СВ одинаковая.
При расчете налогов сумма по счету СВЗ.01.8=18787 задваивается, по счету 69.2.6 сумма в итоге правильная,
но из-за задвоения сумм по счету СВЗ.01.8 в апреле, в мае страховые взносы считаются неверно!
Май - ЗП 250 000, одна проводка, сумма и по 69.2.6 и по СВЗ.01.8 = 5000,
то есть при майском расчете учитываются апрельские задвоеннные суммы,
приведите уже расчет страховых в порядок!!!

Guest_2020
читатель
офлайн
Дата регистрации: 06.05.2020
Сообщений: 9
Пост №2
 
12.06.2020 17:25

в модуле документа "Закрытие месяца", сначала считаем итоговую сумму, потом её распределяем по ТЗ,
а потом делаем проводки по строкам ТЗ, но сумму проводки берем ИТОГОВУЮ, браво!

      ТаблицаРаспределения.ВыбратьСтроки();
                                          Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
                                                СформироватьПроводку("ПФР_ОПС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
                                                Если ВидТарифа = Перечисление.ТарифыСтраховыхВзносов.ДляСубъектовМалогоПредпринимательства Тогда
                                                      СформироватьПроводкуСВЗ("ПФР_ОПС", Сотрудник,ИсчисленоВТекущемМесяце, 0, ТаблицаРаспределения);
                                                      СформироватьПроводкуСВЗ("ПФР_ОПС_МРОТ", Сотрудник, ИсчисленоВТекущемМесяце_ОТ, 0, ТаблицаРаспределения);
                                                Иначе
                                                      СформироватьПроводкуСВЗ("ПФР_ОПС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
                                                КонецЕсли;
                                          КонецЦикла;

Ответили: пост №3
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 644
Пост №3
 
14.06.2020 15:44
Ответ на пост №2

Guest_2020, ещё с 654 релиза заметил эту ошибку. Если два и более начисления по одному и тому же сотруднику в одном месяце с разными счетами затрат или аналитикой/субконто, то суммы по счетам СВЗ.03 задваиваются

Guest_2020
читатель
офлайн
Дата регистрации: 06.05.2020
Сообщений: 9
Пост №4
 
14.06.2020 18:43

и эти задвоенные суммы сказываются при последующих расчетах,
исправил сам , как мог, без претензий на универсальность,
у клиента нет ни инвалидов, ни енвд
может кому пригодится, такое же исправление нужно сделать для ффомс.
                              Если РезультатПФР_ОПС <> 0 Тогда
                                          Если ВидТарифа = Перечисление.ТарифыСтраховыхВзносов.ДляСубъектовМалогоПредпринимательства Тогда
                                                
                                                ТаблицаРаспр­еделения = РаспределитьВзносыПоНачислениям(ИсчисленоВТекущемМесяце, НачисленияПФР, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);                        
                                                
                                                ТаблицаРаспр­еделения.ВыбратьСтроки();
                                                Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
                                                      Сформи­роватьПроводку("ПФР_ОПС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
                                                      Сформи­роватьПроводкуСВЗ("ПФР_ОПС", Сотрудник,ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
                                                КонецЦикла;
                                                
                                                ТаблицаРаспр­еделения = РаспределитьВзносыПоНачислениям(ИсчисленоВТекущемМесяце_ОТ, НачисленияПФР, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);                        
                                                
                                                ТаблицаРаспр­еделения.ВыбратьСтроки();
                                                Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
                                                      Сформи­роватьПроводку("ПФР_ОПС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
                                                      Сформи­роватьПроводкуСВЗ("ПФР_ОПС_МРОТ", Сотрудник,ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
                                                КонецЦикла;
                                          Иначе
                                                ТаблицаРаспр­еделения = РаспределитьВзносыПоНачислениям(РезультатПФР_ОПС, НачисленияПФР, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);                        
                                                
                                                ТаблицаРаспр­еделения.ВыбратьСтроки();
                                                Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
                                                      Сформи­роватьПроводку("ПФР_ОПС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
                                                      Сформи­роватьПроводкуСВЗ("ПФР_ОПС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
                                                КонецЦикла;
                                          КонецЕсли;
                                    КонецЕсли;

Ответили: пост №5
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 644
Пост №5
 
17.06.2020 21:24
Ответ на пост №4

Guest_2020, вышел релиз 7.70.658, пишут что ошибку поправили

Guest_2020
читатель
офлайн
Дата регистрации: 06.05.2020
Сообщений: 9
Пост №6
 
18.06.2020 05:18

Да, исправили.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Представление регламентированной отчетности
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С