Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

8.1: УТ 10.3 "Установка типов цен по группам номенклатуры для покупателей" ОШИБКА!

Re:аниматор
читатель
офлайн
Дата регистрации: 17.05.2008
Сообщений: 55
Пост №1
 
24.01.2010 10:25

"Столкнулся с проблемой не могу провести документ "Установка типов цен по группам номенклатуры для покупателей", выдает сообщение что "Найдены записи о типах цен для групп, которые уже действуют в выбранном периоде:" именно когда Вид операции "по номенклатурным группам"

хотя условия закрыты по дату формирования нового документа, вот модуль от 1С

Процедура ПроверитьПересекающиесяДокументы(Отказ, Заголовок)

Запрос = Новый Запрос;

Запрос.УстановитьПараметр("ДокументСсылка", Ссылка);
Запрос.УстановитьПараметр("ПустойТипЦен", Справочники.ТипыЦенНоменклатуры.ПустаяСсылка());
Запрос.УстановитьПараметр("Дата", ДатаНачала);
Запрос.УстановитьПараметр("Контрагент", Контрагент);

Запрос.Текст = "
|ВЫБРАТЬ РАЗЛИЧНЫЕ
| Док.НоменклатурнаяЦеноваяГруппа КАК Группа,
| РегТипыДляПокупателей.ТипЦен КАК ТипЦен,
| РегТипыДляПокупателей.Период КАК ДатаНачала,
| РегТипыДляПокупателей.Регистратор КАК Регистратор
|ИЗ
| Документ.УстановкаТиповЦенПоГруппамНоменклатурыДляПокупател­ей.НоменклатурныеЦеновыеГруппы КАК Док
|СОЕДИНЕНИЕ Справочник.Номенклатура КАК СпрНоменклатура
|ПО Док.Ссылка = &ДокументСсылка
|И (СпрНоменклатура.НоменклатурнаяГруппа = Док.НоменклатурнаяЦеноваяГруппа
|ИЛИ СпрНоменклатура.ЦеноваяГруппа = Док.НоменклатурнаяЦеноваяГруппа)
|СОЕДИНЕНИЕ РегистрСведений.ТипыЦенПоГруппамНоменклатурыДляПокупателей КАК РегТипыДляПокупателей
|ПО (СпрНоменклатура.НоменклатурнаяГруппа = РегТипыДляПокупателей.НоменклатурнаяЦеноваяГруппа
|ИЛИ СпрНоменклатура.ЦеноваяГруппа = РегТипыДляПокупателей.НоменклатурнаяЦеноваяГруппа)
|И Контрагент = &Контрагент
|УПОРЯДОЧИТЬ ПО Период Возр, Группа Возр, ТипЦен Убыв
|";

ТЗ = Запрос.Выполнить().Выгрузить();

ТЗ.Колонки.Добавить("ДатаОкончания");
ТЗ.ЗаполнитьЗначения('00010101' ,"ДатаОкончания");

КоличествоСтрок = ТЗ.Количество() - 1;
Для Тмп = 0 По КоличествоСтрок Цикл
       СтрокаТЗ = ТЗ[КоличествоСтрок - Тмп];

       Если НЕ ЗначениеЗаполнено(СтрокаТЗ.ТипЦен) Тогда
            Для Тмп1 = 0 По ТЗ.Количество() -1 Цикл
             СтрокаПоиска = ТЗ[Тмп];

             Если СтрокаПоиска.Группа = СтрокаТЗ.Группа
                   И НЕ ЗначениеЗаполнено(СтрокаПоиска.ДатаОкончания) Тогда
                   СтрокаПоиска.ДатаОкончания = СтрокаТЗ.ДатаНачала;
                   ТЗ.Удалить(СтрокаТЗ);
                   Прервать;
             КонецЕсли;
            КонецЦикла;
       КонецЕсли;
КонецЦикла;

СтрокаДокументовПересечений = """";
Для Каждого СтрокаТЗ Из ТЗ Цикл
       Если НЕ ЗначениеЗаполнено(ДатаОкончания) Тогда
            Если СтрокаТЗ.ДатаОкончания > Дата Или НЕ ЗначениеЗаполнено(СтрокаТЗ.ДатаОкончания) Тогда
             СтрокаДокументовПересечений = СтрокаДокументовПересечений + Символы.ПС + СтрокаТЗ.Группа +": " + СтрокаТЗ.Регистратор;
            КонецЕсли;
       Иначе
            Если (ДатаНачала >= СтрокаТЗ.ДатаНачала И ДатаОкончания <= СтрокаТЗ.ДатаОкончания)
             Или (ДатаНачала <= СтрокаТЗ.ДатаНачала И ДатаОкончания >= СтрокаТЗ.ДатаОкончания)
             Или (ДатаНачала <= СтрокаТЗ.ДатаНачала И ДатаОкончания >= СтрокаТЗ.ДатаНачала)
             Или (ДатаНачала <= СтрокаТЗ.ДатаОкончания И ДатаОкончания >= СтрокаТЗ.ДатаОкончания) Тогда
             СтрокаДокументовПересечений = СтрокаДокументовПересечений + Символы.ПС + СтрокаТЗ.Группа +": " + СтрокаТЗ.Регистратор;
            КонецЕсли;
       КонецЕсли;
КонецЦикла;

Если НЕ ПустаяСтрока(СтрокаДокументовПересечений) Тогда
       ОбщегоНазначения.СообщитьОбОшибке("Найдены записи о типах цен для групп, которые уже действуют в выбранном периоде:" + СтрокаДокументовПересечений, Отказ, Заголовок);
       Отказ = Истина;
КонецЕсли;

КонецПроцедуры //ПроверитьПересекающиесяДокументы()

как мне думается, но пропустили цифру 1 или задумка от 1С?

...
КоличествоСтрок = ТЗ.Количество() - 1;
Для Тмп = 0 По КоличествоСтрок Цикл
       СтрокаТЗ = ТЗ[КоличествоСтрок - Тмп];

       Если НЕ ЗначениеЗаполнено(СтрокаТЗ.ТипЦен) Тогда
            Для Тмп1 = 0 По ТЗ.Количество() -1 Цикл
             СтрокаПоиска = ТЗ[Тмп1]; // RR 24.01.2010

             Если СтрокаПоиска.Группа = СтрокаТЗ.Группа
                   И НЕ ЗначениеЗаполнено(СтрокаПоиска.ДатаОкончания) Тогда
                   СтрокаПоиска.ДатаОкончания = СтрокаТЗ.ДатаНачала;
                   ТЗ.Удалить(СтрокаТЗ);
                   Прервать;
             КонецЕсли;
            КонецЦикла;
       КонецЕсли;
КонецЦикла;
...

СтрокаПоиска = ТЗ[Тмп1];

после такого тюнинга модуля все заработало. ошибка это или нет?

тестировалось на релизе "Управление торговлей", редакция 10.3 (10.3.9.4) "

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги