Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как обратиться к элементам в под-папке справочника?

Nati
читатель
офлайн
Дата регистрации: 22.04.2008
Сообщений: 75
Пост №1
 
25.01.2010 14:30

Здравствуйте, подскажите пожалуйста в таком вопросе:
Бух_7.7v_релиз 504
Внешний отчет по которому при выборе контрагента и определенного договора(их несколько разных) выводятся обороты за определенный период. Справочник договора имеет 3 уровня у нас есть вложенные папки Договор202->эта папка имеет несколько папок пр.Договор202/01,Договор202/02 и т.д->а эти папки содержат элементы(объекты): 202/01/01МодернизацияУзлов и т.д.Изначально требовалось формировать только по под-папке кот. напрямую содержит элементы т.е. Договор202/02, а сейчас им необходимо по всей группе Договора202 т.е. они создали общую папку Договор202 и в ней уже все остальные папки и выбирают папку Договор202,а по ней ноль оборотов.
Незнаю как программно обратиться к под-папкам в которых находятся элементы(объекты).

mar2010
читатель
офлайн
Дата регистрации: 25.01.2010
Сообщений: 66
Пост №2
 
25.01.2010 18:27

текст программы пиши - тогда подскажем

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
25.01.2010 19:00

НайтиПоКоду ?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №4
 
25.01.2010 20:59

"БухИт.ИспользоватьСубконто(ВидСубконто.Договоры, ВыбраннаяГруппаДоговоров, 1, 0);

так не работает что ли?"

Nati
читатель
офлайн
Дата регистрации: 22.04.2008
Сообщений: 75
Пост №5
 
26.01.2010 07:09

"Процедура Заполнить()
-//-

Опер = СоздатьОбъект("Операция");
Опер.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент);
Если ПустоеЗначение(Договор) = 0 Тогда
Если Договор.ЭтоГруппа() = 0 Тогда
Опер.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор);

Иначе Если Договор.ЭтоГруппа() = 1 Тогда
                   ????
//Опер.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор);
КонецЕсли;
КонецЕсли;
КонецЕсли;
Опер.ВыбратьОперацииСПроводками(НачДата, КонДата, Фильтр);
Пока Опер.ПолучитьПроводку() = 1 Цикл

СчДт = Опер.Дебет.Счет;
СчКт = Опер.Кредит.Счет;
ПервичныйДокумент = СокрЛП(Опер.ПервичныйДокумент);
СчетГруппаДт = СчДт.Родитель(1);
СчетГруппаКт = СчКт.Родитель(1);
       -//-"

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №6
 
26.01.2010 09:48

"Иначе Если Договор.ЭтоГруппа() = 1 Тогда
//составить список договоров в папке Договор
СписокДоговоров=СоздатьОбъект("СписокЗначений");
Спр = СоздатьОбъект("Справочник.Договоры");
Спр.ИспользоватьРодителя(Договор);
Спр.ВыбратьЭлементы(1);
Пока Спр.ПолучитьЭлемент() = 1 Цикл
       Если Спр.ЭтоГруппа() = 0 Тогда
            СписокДоговоров.ДобавитьЗначение(Спр.ТекущийЭлемент());
       КонецЕсли;
КонецЦикла;      
Опер.ИспользоватьСубконто(ВидыСубконто.Договоры, СписокДоговоров);
КонецЕсли;
"

Nati
читатель
офлайн
Дата регистрации: 22.04.2008
Сообщений: 75
Пост №7
 
26.01.2010 11:05

Спасибо, но вот это выбирает элементы только если в этой папке которая выбрана находятся те самые элементы, а у меня в этой папке 5 папок в которых и есть элементы по которым формируются обороты. Получается что выбрав папку Договор202(кот. содержит папки Договор202/01, Договор202/02 и т.д.)он выводит нулевые обороты т.е. он не доходит до элементов внутренних папок(напр. папка Договор202/01 содержит элементы: 202/01/1 Ремонт труб, 202/01/2 модернизация блоков и т.д. по которым есть обороты).Вот если выбрать папку Договор202/01 то сформируется таблица с оборотами по элементам которые там находятся, а надо чтоб по всей папке Договор202 т.е.чтоб собрал все элементы этого договора202.

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №8
 
26.01.2010 14:47

Спр.ПолучитьЭлемент(1)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги