Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1c 7.7 Печать в отчете..

AnyaIv
читатель
офлайн
Дата регистрации: 06.02.2010
Сообщений: 1
Пост №1
 
07.02.2010 19:58

Подскажите пожалуйста.. Вот есть Справочник Сотрудники и подчиненный ему справочник подразделения. Надо вывести на печать в отчете ФИО сотрудников по выбранному в диалоге подразделению..
Пробовала через запрос, но почему то не срабатывает условия... Может кто подскажет как прально осуществить :) Заранее спасибо!

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
07.02.2010 23:09

> Подскажите пожалуйста.. Вот есть Справочник Сотрудники и подчиненный ему справочник подразделения.
что за конфигурация такая странная?


> Пробовала через запрос, но почему то не срабатывает условия... Может кто подскажет как прально осуществить :) Заранее спасибо!
>

так где код, который не получился ?

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №3
 
13.02.2010 22:35

"Подр=СоздатьОбъект("Справочник.Подразделения");
Подр.ВыбратьЭлементыПоРеквизиту("Подразделение", ВыбПодразделение);
Пока Подр.ПолучитьЭлемент()=1 Цикл
Сообщить(Подр.Владелец.ФИО);
КонецЦикла"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
13.02.2010 22:55

"> Подр=СоздатьОбъект("Справочник.Подразделения");
> Подр.ВыбратьЭлементыПоРеквизиту("Подразделение", ВыбПодразделение);
> Пока Подр.ПолучитьЭлемент()=1 Цикл
> Сообщить(Подр.Владелец.ФИО);
> КонецЦикла

у справочника подразделение есть реквизит подразделение ? о_О"

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №5
 
13.02.2010 23:01

я не знаю что есть в его конфигурации в справочнике подразделения, я всего лиш написал пример

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №6
 
14.02.2010 09:26

"А я понял так:
Имеется справочник "Сотрудники", в котором есть периодический реквизит "Подразделение", нужно вывести список сотрудников подразделения, которое выбрано в форме.

ТекстЗапроса="Период с НужнаяДата по НужнаяДата;
|Сотрудник=Справочник.Сотрудники.ТекущийЭлемент;
|Подразделение=Справочник.Сотрудники.Подразделение;
|Условие(Подразделение=НужноеПодразделение);
|Группировка Сотрудник без групп упорядочить по Сотрудник.Наименование;";

Запрос=СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
Пока Запрос.Группировка(1)=1 Цикл
       ...
КонецЦикла;
КонецЕсли;"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги