Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1с 7.7 Бухгалтерия. Как отобрать элемент справочника по неполному наименованию

Zabey
читатель
офлайн
Дата регистрации: 07.12.2009
Сообщений: 39
Пост №1
 
14.02.2010 16:47

"Вот функция которая якобы должна осуществлять поиск и отбор элементов:

Функция Только(НомКуз)
Если НомКуз.Вид() = "Автомобили" Тогда
Если (НомКуз.Наименование) = "e39" Тогда
       Возврат 1;                                                
       КонецЕсли;
КонецЕсли;
Возврат 0;
КонецФункции

Проблема в том что модели автомобилей в справочнике имеют наименование типа:
"e39 525i m52", "e39 540i m60", "e46 316i n42", "e60 540i n62" и т.д.

нужно чтобы отбор происходил только по "е39"

Кто может подсказать как решить проблемку?
"

BelAS
читатель
офлайн
Дата регистрации: 11.12.2002
Сообщений: 542
Пост №2
 
14.02.2010 21:11

Воспользоваться стандартной функцией
Найти(<Строка1>,<Строка2>)
Назначение:
Возвращает позицию первого вхождения в строку поиска заданной подстроки.

Zabey
читатель
офлайн
Дата регистрации: 07.12.2009
Сообщений: 39
Пост №3
 
15.02.2010 15:45

после написания темы через пол часа сразу же нашел решение проблемы в такой загагулине)))
Если Лев(НомКуз.Наименование,3) = "e39" Тогда

все получилось)всем спасибо)

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
15.02.2010 16:05

> Вот функция которая якобы должна осуществлять поиск и отбор элементов:
это код в файле метаданных 1cv7.md ?

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №5
 
15.02.2010 16:06

> после написания темы через пол часа сразу же нашел решение проблемы в такой загагулине)))
> Если Лев(НомКуз.Наименование,3) = "e39" Тогда
>
> все получилось)всем спасибо)
>

НЕПРАВИЛЬНАЯ РЕАЛИЗАЦИЯ !

Zabey
читатель
офлайн
Дата регистрации: 07.12.2009
Сообщений: 39
Пост №6
 
17.02.2010 19:59

что значит неправильная если результат опробован кучей различных вариаций)?
зачем городить кучу строк если в одной все уместилось и работает без потери ресурсов??

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №7
 
18.02.2010 11:40

Разбор строк сам по себе - достаточно ресурсоемкая задача, поэтому самым верным решением является наличие в справочнике автомобилей отдельного реквизита "модель" и проведение выборок/группировок с конкретизацией ссылок на нужные элементы отдельного справочника "модели автомобилей".

Zabey
читатель
офлайн
Дата регистрации: 07.12.2009
Сообщений: 39
Пост №8
 
18.02.2010 19:01

это внешняя обработка

Zabey
читатель
офлайн
Дата регистрации: 07.12.2009
Сообщений: 39
Пост №9
 
19.02.2010 08:35

да и собственно фильтр надо сделать более чем по 30 моделям... так что группировку городить такого размера не посчитал целесообразным...

Zabey
читатель
офлайн
Дата регистрации: 07.12.2009
Сообщений: 39
Пост №10
 
19.02.2010 08:48

причем каждую модель я повесил на флажок

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги