Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Печать без предварительного просмотра работает криво из групповой обработки документов.

a-hunter
читатель
офлайн
Дата регистрации: 29.07.2009
Сообщений: 8
Пост №1
 
15.02.2010 14:10

Проблема такая: при печати нескольких документов через групповую обработку справочников и документов в бухгалтерии 1с8.1, при режиме печать без предварительного просмотра, при печати каждого документа на экран вылазит окно с выбором принтера, и надо тупо сидеть и клацать мышкой по кнопке печать. Но самое интересное что из другой базы - с точно такой же конфигурацией всё делается без этого косяка, т.е. запустил печать и ничего нажимать не надо, можно сходить попить чаю. И этот глюк на всех компьютерах в чем тут прикол не понимаю. Единственное различие в базах ,это то что база из которой приходиться постоянно нажимать на кнопку печать в окне выбора принтера - создана недавно, но повторюсь - конфигурации идентичны. Лазил по коду - там всё правильно и красиво =(((

Может кто то сталкивался?

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №2
 
15.02.2010 14:17

> но повторюсь - конфигурации идентичны

А что это вообще за конфигурации?

a-hunter
читатель
офлайн
Дата регистрации: 29.07.2009
Сообщений: 8
Пост №3
 
15.02.2010 14:33

бухгалтерия 1.6.21.6

Vovan1975
читатель
офлайн
Дата регистрации: 25.01.2010
Сообщений: 124
Пост №4
 
15.02.2010 16:43

Посмотрите в справочнике "Пользователи" у пользователя, из-под которого обработку запускаете, настройку "Печать документов без предварительного просмотра". Может из-за этого...

a-hunter
читатель
офлайн
Дата регистрации: 29.07.2009
Сообщений: 8
Пост №5
 
15.02.2010 17:45

нет. эта настройка предназначена для печати без просмотра из документов, к обработке эта настройка никакого отношения не имеет.

EAX88
читатель
офлайн
Дата регистрации: 23.06.2008
Сообщений: 159
Пост №6
 
15.02.2010 22:17

"Модуль объекта обработка "ГрупповаяОбработкаСправочниковИДокументов" строка 141
Если УниверсальныеМеханизмы.НапечататьДокументПоУмолчанию(Объект, , НаПринтер) Тогда
Сообщить(Ссылка);
КонецЕсли;
Надо заменить на:
Если УниверсальныеМеханизмы.НапечататьДокументПоУмолчанию(Объект, , НаПринтер, ИСТИНА) Тогда
Сообщить(Ссылка);
КонецЕсли;

"

a-hunter
читатель
офлайн
Дата регистрации: 29.07.2009
Сообщений: 8
Пост №7
 
16.02.2010 10:12

Спасибо большое. Помогло.

hatabanchik
читатель
офлайн
Дата регистрации: 16.08.2010
Сообщений: 2
Пост №8
 
16.08.2010 15:02

"У меня подобная ситуация. У меня при групповой печати счетов фактур выданных печатается без предварительного просмотра на принтер. Все отлично. Я добавляю свою собственную внешнюю форму, в которой чуть чуть другой макет. И устанавливаю эту форму по умолчанию. Точно так же делаю групповую обработку, устанавливаю без просмотра, а он мне все равно все их открывает.
Вот это сделал
Модуль объекта обработка "ГрупповаяОбработкаСправочниковИДокументов" строка 141
Если УниверсальныеМеханизмы.НапечататьДокументПоУмолчанию(Объект, , НаПринтер) Тогда
Сообщить(Ссылка);
КонецЕсли;
Надо заменить на:
Если УниверсальныеМеханизмы.НапечататьДокументПоУмолчанию(Объект, , НаПринтер, ИСТИНА) Тогда
Сообщить(Ссылка);
КонецЕсли;
Не помогло.
Может кто-нить сталкивался?"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №9
 
16.08.2010 17:12

Надо видеть код вашей ВПФ.

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №10
 
16.08.2010 19:59

В вашей ВПФ функция модуля объекта Печать() должна возвращать Табличный Документ, а не печатать его, чтобы групповая обработка корректно обработала.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги