Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Работа со справочниками

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №1
 
24.02.2010 11:58

Есть ситуация в справочнике номенклатура есть позиции с одинаковыми артикулами, как программно можно сделать повторяющиеся артикулы разными, т.е. найти элементы с одинаковыми артикулами и один из них сделать другим? например есть 2 элемента с артикулом "ААА", надо один элемент оставить таким же, а второй "ААА_", подскажите плиз

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
24.02.2010 12:04

наименование конфигурации ?
+ типовая или нет ?

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №3
 
24.02.2010 12:06

комплексная 7.7

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
24.02.2010 13:15

"потренируйся на копии, вот примерный код:

МоёЗначениеАртикула = "ААА";
НовоеЗначениеАтикула = "ААА_";
Спр = СоздатьОбъект("Справочник.Номенклатура");
Если Спр.ВыбратьЭлементыПоРеквизиту("Артикул",МоёЗначениеАртикула,0,1)=0 Тогда
Сообщить("нет такого реквизита");
КонецЕсли;
Спр.ПолучитьЭлемент();
Спр.Артикул = НовоеЗначениеАтикула;
Спр.Записать();"

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №5
 
24.02.2010 14:30

суть в том что повторяющихся артикулов много, и какие они я незнаю, если бы был 1 то я бы ручками поменял, т.е.:
есть в справочнике колонка артикул и выглядит примерно так
1.ААА
2.ААА
3.BBB
4.CCC
5.CCC
6.DDD
7.EEE
8.FFF
9.FFF
а мне надо чтобы выглядело так:
1.ААА
2.ААА_
3.BBB
4.CCC
5.CCC_
6.DDD
7.EEE
8.FFF
9.FFF_

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
24.02.2010 14:45

ясно...

они необязательно задвоены ?

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №7
 
24.02.2010 15:26

да необязательно, просто это произошло из-за некорректного заполнения справочника, у меня переносом из другой базы ищет по артикулу, а бухгалтера зачем-то заносили ручками некоторое время и не ставили артикул, поэтому создаваля новый товар

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №8
 
24.02.2010 15:41

> да необязательно, просто это произошло из-за некорректного заполнения справочника, у меня переносом из другой базы ищет по артикулу, а бухгалтера зачем-то заносили ручками некоторое время и не ставили артикул, поэтому создаваля новый товар

1. делаешь запрос по справочнику - получаешь СЗ совсеми возможными Артикулами...
2. далее делаешь запрос для каждого и заменяешь

первое, что на мысль пришло

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №9
 
24.02.2010 17:09

"ТекстЗапроса="Товар=Справочник.Номенклатура.ТекущийЭлемент;
             |Артикул=Справочник.Номенклатура.Артикул;
             |Группировка Артикул;
             |Группировка Товар без групп без упорядочивания;";

Запрос=СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
Номенклатура=СоздатьОбъект("Справочник.Номенклатура");
Пока Запрос.Группировка(1)=1 Цикл
       ТекАртикул=СокрЛП(Запрос.Артикул);
       Если ПустаяСтрока(ТекАртикул)=0 Тогда
             Счетчик=0;
             Пока Запрос.Группировка(2)=1 Цикл
                   Счетчик=Счетчик+1;
                   Если Счетчик>1 Тогда
                         Если Номенклатура.НайтиЭлемент(Запрос.Товар)=1 Тогда
                              Номенклатура.Артикул=ТекАртикул+?(Счетчик=2,"_",Строка(Счетчик)); //а вдруг дубликатов много?! в результате такого будет "ААА", "ААА_", "ААА2", "ААА3"...
                              Номенклатура.Записать();
                         КонецЕсли;
                   КонецЕсли;
             КонецЦикла;
       КонецЕсли;
КонецЦикла;
КонецЕсли;"

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №10
 
26.02.2010 10:20

спс

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги