Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Картинка в справочнике 1С8.2

step1207
читатель
офлайн
Дата регистрации: 09.03.2010
Сообщений: 6
Пост №1
 
10.03.2010 09:48

"Пишу конфу для учета сотовых в СЦ,столкнулся с проблемой вывода картинки изделия на форме справочника воспользовался синтаксис помошником и взял код

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Заголовок = "Выберите файл с фотографией";
Диалог.ПолноеИмяФайла = """";
Диалог.ПредварительныйПросмотр = Истина;
Диалог.Фильтр =
"Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
+ "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
+ "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
+ "Формат TIFF (*.tif)|*.tif|"
+ "Формат GIF (*.gif)|*.gif|"
+ "Формат PNG (*.png)|*.png|"
+ "Формат icon (*.ico)|*.ico|"
+ "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|"; // картинки

Если Диалог.Выбрать() Тогда
ВыбранноеФото = Новый Картинка(Диалог.ПолноеИмяФайла,Ложь);
ЭлементыФормы.ПолеИзображения.Картинка = ВыбранноеФото;
Иначе
Отказ = Истина;
Возврат;
КонецЕсли;

Картинка отображается но после записи не сохраняется,может кто подскажет что делать?"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №2
 
10.03.2010 10:16

Не знаю как в 8.2, а в 8.1 было 2 варианта:
1. Двинуть картинку в папку на сервер и дать её уникальное имя. Путь сохранить в справочнике и выводить использую эти данные.
2. Через ПолучитьДвоичныеДанные и ХранилищеЗначения сохранить в реквизит справочника. Для вывода использовать обратную процедуру :)

step1207
читатель
офлайн
Дата регистрации: 09.03.2010
Сообщений: 6
Пост №3
 
10.03.2010 11:43

А если этих картинок будет много то как быть?Возможен такой вариант как в семерке,сейчас точно не помню как пишется но что-то вроде так(каталогИБ\*.jpeg\+код+)!

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №4
 
10.03.2010 14:33

Вопрос не ясен.
Картинку вы уже выбрали. Проблема была в том, что она не сохраняется. Как сохранить - я написал. А что вы пытались сказать - не ясно.

step1207
читатель
офлайн
Дата регистрации: 09.03.2010
Сообщений: 6
Пост №5
 
10.03.2010 15:06

Допустим,я выбираю из справочника уже сохраненную модель телефона а в ПолеКартинка появится не та картинка что я сохранил, как конфа будет выбирать именно эту картинку? ведь при сохранении справочника сохраняется код,наименование и родитель!

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №6
 
10.03.2010 16:18

> Допустим,я выбираю из справочника уже сохраненную модель телефона а в ПолеКартинка появится не та картинка что я сохранил, как конфа будет выбирать именно эту картинку?
По пути из реквизита или из реквизита восстановив из Хранилища
> ведь при сохранении справочника сохраняется код,наименование и родитель!
А реквизиты по вашему не сохраняются???

step1207
читатель
офлайн
Дата регистрации: 09.03.2010
Сообщений: 6
Пост №7
 
11.03.2010 09:33

"ерем РаботаСФайлами;
Процедура ОсновноеИзображениеНажатие(Элемент)
// Вставить содержимое обработчика.
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Заголовок = "Выберите файл с фотографией";
Диалог.ПолноеИмяФайла = """";
Диалог.ПредварительныйПросмотр = Истина;
Диалог.Фильтр =
"Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
+ "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
+ "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
+ "Формат TIFF (*.tif)|*.tif|"
+ "Формат GIF (*.gif)|*.gif|"
+ "Формат PNG (*.png)|*.png|"
+ "Формат icon (*.ico)|*.ico|"
+ "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|"; // картинки

Если Диалог.Выбрать() Тогда
ВыбранноеФото = Новый Картинка(Диалог.ПолноеИмяФайла,Ложь);
ЭлементыФормы.ОсновноеИзображение.Картинка = ВыбранноеФото;
Иначе
Отказ = Истина;
Возврат;
КонецЕсли;



Хранилище = Новый ХранилищеЗначения(ОсновноеИзображение);

// сохранение значения типа ХранилищеЗначения в базе данных
НовНоменклатура = Справочники.Модель.СоздатьЭлемент();
НовНоменклатура.Наименование = "Диван """"Маргарита""""";
// реквизит Изображение имеет тип ХранилищеЗначения
НовНоменклатура.ОсновноеИзображение = ОсновноеИзображение;
НовНоменклатура.Записать();
// выгрузка значения типа ДвоичныеДанные из хранилища значений в файл
ИмяФайла = "C:\Мои документы\Картинка2.bmp";
НовНоменклатура.ОсновноеИзображение.Получить().Записать(ИмяФайла);

КонецПроцедуры


Как из всего это вызвать картинку в поле изображения я не знаю или делаю что-то не то подскажите уже задолбало"

step1207
читатель
офлайн
Дата регистрации: 09.03.2010
Сообщений: 6
Пост №8
 
11.03.2010 10:52

"{Справочник.Модель.Форма.ФормаЭлемента(29)}: Значение не является значением объектного типа (Изображение)
Картинка = РегистрСведенийМенеджерЗаписи.Изображение.Получить();
Как это понять?"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №9
 
11.03.2010 12:20

"Выбор картинки оставляем как есть, а вот дальше:
>
> Хранилище = Новый ХранилищеЗначения(ОсновноеИзображение);
Интересный вопрос, а что такое у вас "ОсновноеИзображение"? На форме лежит ПолеКартинка, данных у неё нет, и где определяется "ОсновноеИзображение" не ясно. Я написал так:
Хранилище = Новый ХранилищеЗначения(ЭлементыФормы.ОсновноеИзображение.Картинка.ПолучитьДвоичныеДанные());
>
> // сохранение значения типа ХранилищеЗначения в базе данных
> НовНоменклатура = Справочники.Модель.СоздатьЭлемент();
> НовНоменклатура.Наименование = "Диван """"Маргарита""""";
> // реквизит Изображение имеет тип ХранилищеЗначения
Это оставим, а дальше - не верно:
> НовНоменклатура.ОсновноеИзображение = ОсновноеИзображение;
Должно бы быть так:
НовНоменклатура.ОсновноеИзображение = Хранилище;
> НовНоменклатура.Записать();

Зачем следующее - мне не понятно.
> // выгрузка значения типа ДвоичныеДанные из хранилища значений в файл
> ИмяФайла = "C:\Мои документы\Картинка2.bmp";
> НовНоменклатура.ОсновноеИзображение.Получить().Записать(ИмяФайла);
>

> КонецПроцедуры

Итак - Сохранение сделано. Теперь восстановление: (предположим на форме лежит ПолеКартинки1):

Процедура ПоказатьКартинку (пНоменклатура)
       Если ТипЗнч(пНоменклатура.ОсновноеИзображение) = Тип("ХранилищеЗначения") Тогда
ЭлементыФормы.ПолеКартинки1.Картинка = Новый Картинка (пНоменклатура.ОсновноеИзображение.Получить());
КонецЕсли;
КонецПроцедуры

Все. При этом картинка храниться в базе.

з.ы. Все это на 8.1, учитывая следующее сообщение, возможно что-то надо переделать под 8.2 (может нет у него типа Картинка, а теперь тип Изображение и тогда надо смотреть его свойства, конструкторы, методы)"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №10
 
11.03.2010 12:27

"Не знаю что такой тип Изображение - это уже видимо свойства 8.2.
В случае с 8.1 ругань про картинку. А у картинки есть конструктор:

Картинка = Новый Картинка(РегистрСведенийМенеджерЗаписи.Изображение.Получить());"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги