Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

7.7. Комплексная Отображение остатков товара в документах

spyblack
читатель
офлайн
Дата регистрации: 25.03.2010
Сообщений: 4
Пост №1
 
25.03.2010 11:56

"Вопрос следующего характера:
В счете-фактуре и в расходной накладной отображаются остатки товара на всех складах.
Как сделать что бы отображались остатки только определенного (основного) склада?

В расходной накладной остаток отображается:

Функция Остаток()
Если (Товар.Выбран() = 0) Или (Константа.ПоказыватьОстаткиТМЦ = Нет) Тогда
Возврат """";
КонецЕсли;
Возврат глКонтрольОстатка(Контекст,ОстаткиТоваров,РезервыТоваров);
КонецФункции

В счете-фактуре:

Функция УстОстаток()
Возврат СокрЛП(Формат(РегОстаткиТоваров.СводныйОстаток(Фирма,ТМЦ,ТекСклад,,"ОстатокТовара"), "Ч12.5"));
КонецФункции

1С 7.7 бухгалтерия+торговля+склад+зарплата+кадры 7.70.019

"

its-saratov
читатель
офлайн
Дата регистрации: 24.03.2010
Сообщений: 14
Пост №2
 
25.03.2010 13:54

с какого торрента вестимо?)) "7.70.019"??)))

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
25.03.2010 14:20

1. (Константа.ПоказыватьОстаткиТМЦ = Нет) - что такое нет ?
2. комплексная укр ?

spyblack
читатель
офлайн
Дата регистрации: 25.03.2010
Сообщений: 4
Пост №4
 
25.03.2010 14:26

чем релиз не понравился? какой уж есть

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №5
 
25.03.2010 14:27

> чем релиз не понравился? какой уж есть

просто некоторые думают, что 1с только в России ! :-)

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
25.03.2010 14:27

(Константа.ПоказыватьОстаткиТМЦ = Нет) - что такое нет ?

spyblack
читатель
офлайн
Дата регистрации: 25.03.2010
Сообщений: 4
Пост №7
 
25.03.2010 14:27

7.70.021 если уж уточнить

spyblack
читатель
офлайн
Дата регистрации: 25.03.2010
Сообщений: 4
Пост №8
 
25.03.2010 14:31

Нет - это условие которое ставиться в константах
Показывать ли остатки ТМЦ в документах значение ДА

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №9
 
25.03.2010 14:32

какой тип значения у "нет" ?

IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №10
 
25.03.2010 18:09

"А если попробовать:
> Возврат СокрЛП(Формат(Регистр.РегОстаткиТоваров.Остаток(Фирма,ТМЦ,ТекСклад,,"ОстатокТовара"),"Ч12.5"));

"Нет" это похоже на Перечисление.Булево.Нет
И соответственно в глобальном модуле должно быть, что-то типа
> Нет=Перечисление.Булево.Нет;"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги