Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

внешняя печатная форма

Зюзюка
читатель
офлайн
Дата регистрации: 21.04.2010
Сообщений: 5
Пост №1
 
06.05.2010 17:07

создаю внешнюю печатную форму ведомости МБ-7,
скопировал макет и модуль объекта из документа передача материалов в эксплуатацию
при вызове ВПФ ведомости МБ - 7 пишет:
не удалось сформировать ВПФ
Недостаточно фактических параметров

Помогите люди добрые

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
06.05.2010 19:58

1. номер версии 1с
2. а где код

Зюзюка
читатель
офлайн
Дата регистрации: 21.04.2010
Сообщений: 5
Пост №3
 
07.05.2010 09:36

"версия 8.1
релиз 1.6.24.7


Код:
// Функция формирует печатную форму документа МБ-7
//
Функция ПечатьМБ7()Экспорт

Запрос = Новый Запрос;

Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);

Запрос.Текст =
"ВЫБРАТЬ
| Номер                   КАК НомерДокумента,
| Дата                   КАК ДатаДокумента,
| Дата                   КАК ДатаСоставления,
| Организация             КАК Организация,
| Склад                   КАК Склад,
| ПодразделениеОрганизации КАК Подразделение
|ИЗ
| Документ.ПередачаМатериаловВЭксплуатацию КАК ПередачаМатериаловВЭксплуатацию
|
|ГДЕ
| ПередачаМатериаловВЭксплуатацию.Ссылка = &ТекущийДокумент";

Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
Запрос.УстановитьПараметр("Организация", Шапка.Организация);
Запрос.УстановитьПараметр("Дата",            Шапка.ДатаДокумента);

Запрос.Текст =
"ВЫБРАТЬ
| Спецодежда.НомерСтроки КАК НомерПП,
| Спецодежда.Номенклатура.Код КАК НоменклатурныйНомер,
| ВЫРАЗИТЬ(Спецодежда.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК ТоварНаименование,
| Спецодежда.Номенклатура.БазоваяЕдиницаИзмерения.Код КАК ЕдиницаИзмеренияКод,
| Спецодежда.Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК ЕдиницаИзмеренияНаименование,
| Спецодежда.Количество КАК Количество,
| Спецодежда.ФизЛицо КАК Сотрудник,
| РаботникиОрганизацийСрезПоследних.ТабельныйНомер,
| Спецодежда.Ссылка.Дата КАК ДатаДокумента,
| Спецодежда.НазначениеИспользования.СрокПолезногоИспользования КАК СрокСлужбы
|ИЗ
| Документ.ПередачаМатериаловВЭксплуатацию.Спецодежда КАК Спецодежда
| ЛЕВОЕ СОЕДИНЕНИЕ
| (ВЫБРАТЬ
| РаботникиОрганизацийСрезПоследних.Сотрудник.Код КАК ТабельныйНомер,
| РаботникиОрганизацийСрезПоследних.Сотрудник.ФизЛицо КАК ФизЛицо,
| РаботникиОрганизацийСрезПоследних.Должность КАК Должность,
| РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации КАК ПодразделениеОрганизации
| ИЗ
| РегистрСведений.РаботникиОрганизаций.СрезПоследних(&Дата, Организация = &Организация) КАК РаботникиОрганизацийСрезПоследних
| ГДЕ
| РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния <> ЗНАЧЕНИЕ(Перечисление.ПричиныИзмененияСостояния.Увольнение)
| ) КАК РаботникиОрганизацийСрезПоследних
| ПО Спецодежда.ФизЛицо = РаботникиОрганизацийСрезПоследних.Физлицо
|ГДЕ
| Спецодежда.Ссылка = &ТекущийДокумент
|
|УПОРЯДОЧИТЬ ПО
| НомерПП";
ВыборкаПоСтрокам = Запрос.Выполнить().Выбрать();

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПередачаМатериаловВЭксплуатацию_МБ7";

// Вывод заголовка
Макет = ПолучитьМакет("МБ7");
Область = Макет.ПолучитьОбласть("Заголовок");
Область.Параметры.Заполнить(Шапка);

СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.ДатаДокумента);

Область.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);
Область.Параметры.ПредставлениеПодразделения = Шапка.Подразделение;
Область.Параметры.ОрганизацияПоОКПО       = СведенияОбОрганизации.КодПоОКПО;

ТабДокумент.Вывести(Область);

Пока ВыборкаПоСтрокам.Следующий() Цикл

Область = Макет.ПолучитьОбласть("Строка");
Область.Параметры.Заполнить(ВыборкаПоСтрокам);
Область.Параметры.ТоварНаименование = СокрЛП(ВыборкаПоСтрокам.ТоварНаименование);
ТабДокумент.Вывести(Область);

КонецЦикла;

// Вывод подвала
Область = Макет.ПолучитьОбласть("Подписи");
ТабДокумент.Вывести(Область);

Возврат ТабДокумент;

КонецФункции // ПечатьМБ7()





// Процедура осуществляет печать документа. Можно направить печать на
// экран или принтер, а также распечатать необходмое количество копий.
//
// Название макета печати передается в качестве параметра,
// по переданному названию находим имя макета в соответствии.
//
// Параметры:
// НазваниеМакета - строка, название макета.
//
Функция Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь, НепосредственнаяПечать = Ложь) Экспорт

// Получить экземпляр документа на печать
Если      ИмяМакета = "МБ7" Тогда
ТабДокумент = ПечатьМБ7();
ИначеЕсли ИмяМакета = "М11" Тогда
ТабДокумент = ПечатьМ11();

КонецЕсли;

УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка), НепосредственнаяПечать);

КонецФункции // Печать()
"

ВРедная
читатель
офлайн
Дата регистрации: 03.02.2007
Сообщений: 954
Пост №4
 
07.05.2010 13:28

Почитайте справку с внешним печатным формам, в частности:


Требования к подключению внешних обработок:
<...>
Внешняя печатная форма.
Внешняя обработка содержащая:
<...>
Функция «Печать()» - без параметров, возвращающая табличный документ.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги