Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

Ошибка выражения

Vlad_Oks
читатель
офлайн
Дата регистрации: 28.01.2013
Сообщений: 66
Пост №1
 
27.03.2013 13:59

"Добрый день, текст в модуле формы, подскажите в чем возможна ошибка, в отладчке при "вычислить выражение" пишет<br>Если ДатаДок < Дата ('01.01.2013') = ошибка выражения! (соответственно она туда не заходит)<br>текст в модуле:<br>//ДатаДок - это дата документа<br>------------------------------<br>ДатаИзм = Дата ("20130101");<br>ДатаДокумента = Дата(ДатаДок);<br>Если ДатаДокумента < ДатаИзм Тогда <br> НачалоОтсчета = ДобавитьМесяц(НачалоГода,-1);<br>Иначе <br>      НачалоОтсчета = Дата(ГодУходаНаПенсию-1,ДатаМесяц(ДатаРожд),ДатаЧисло(ДатаРожд)); <br>       КонецОтсчета = Дата(ГодУходаНаПенсию,ДатаМесяц(ДатаРожд)-1,ДатаЧисло(ДатаРожд));<br>КонецЕсли<br>------------------------------<br> <br>в чем это выражение не верно?"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
27.03.2013 14:06

"конструкция в 77 не работает ?<br><br>Если ДатаДок < Дата ('01.01.2013') Тогда<br><br>КонецЕсли;"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
27.03.2013 14:06

в 7ке<br><br>Дата ("20130101") == Дата(0)

Vlad_Oks
читатель
офлайн
Дата регистрации: 28.01.2013
Сообщений: 66
Пост №4
 
27.03.2013 14:27

Да, данная конструкция не работает в 77, что не так пишу?

Отшельник
читатель
офлайн
Дата регистрации: 04.02.2008
Сообщений: 279
Пост №5
 
27.03.2013 14:52

Должно быть Дата(<Год>,<Месяц>,<Число>), Где Год, Месяц, и Число - числовые выражения

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
27.03.2013 14:54

странно, у меня работает

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №7
 
27.03.2013 14:55

есть два написания

Отшельник
читатель
офлайн
Дата регистрации: 04.02.2008
Сообщений: 279
Пост №8
 
27.03.2013 15:02

Если писать Дата ("20130101") - Выдает строку = . . <br>Нужно писать Дата("2013","01","01") или Дата ('01.01.2013')

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №9
 
27.03.2013 15:18

я про Дата ('01.01.2013')

Vlad_Oks
читатель
офлайн
Дата регистрации: 28.01.2013
Сообщений: 66
Пост №10
 
27.03.2013 15:19

"Тогда как мне правильнее в 77 сделать сравнение?<br>Так:<br>-----------------------<br>Если ДатаДокумента < '01.01.13' Тогда<br> НачалоОтсчета = ДобавитьМесяц(НачалоГода,-1);<br>Иначе<br>      НачалоОтсчета = Дата(ГодУходаНаПенсию-1,ДатаМесяц(ДатаРожд),ДатаЧисло(ДатаРожд))$<br>КонецЕсли<br>---------------------------------------<br>Или<br>------------------------------------------------ <br>Если ДатаДокумента < Дата('2013','01','01') Тогда<br> НачалоОтсчета = ДобавитьМесяц(НачалоГода,-1);<br>Иначе<br>      НачалоОтсчета = Дата(ГодУходаНаПенсию-1,ДатаМесяц(ДатаРожд),ДатаЧисло(ДатаРожд))$<br>КонецЕсли<br> <br>???"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С