Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Загрузить в поле ввода текст из файла

Илья Привалов
читатель
офлайн
Дата регистрации: 13.10.2017
Сообщений: 13
Пост №1
 
13.10.2017 09:57

1С8.3 Конфигурация самописная, пишу обработку для рассылки почты, помимо общего функционала должна быть возможность выгрузить текст из файла в поле ввода ТекстПисьма, испытываю затруднения при выводе текста в поле, подскажите, как вывести не только текущую строку, а все строки документа по очереди?


Процедура ЗагрузитьТекстИзФайла(Элемент, ДанныеВыбора, СтандартнаяОбработка)
      
Перем Стр;
ДТФ = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДТФ.Заголовок = "Выберите файл (*.TXT/.RTF.HTML*)";
ДТФ.Фильтр = "Текстовый Документ (*.txt;*.doc;*.rtf)|*.txt;*.doc;*.rtf|";
ДТФ.ПредварительныйПросмотр=Ложь;
ДТФ.ПроверятьСуществованиеФайла=Истина;
Если ДТФ.Выбрать() Тогда
      
ПутьКТфайлу = ДТФ.ПолноеИмяФайла;
КонецЕсли;
      Текст = Новый ТекстовыйДокумент;
      Текст.Прочитать(ПутьКТФайлу);
      КоличествоСтрок = Текст.КоличествоСтрок();
Для Счетчик = 1 по КоличествоСтрок Цикл
ТекСтрока = Текст.ПолучитьСтроку(Счетчик);
Сообщить(ТекСтрока);
      ТекстПисьма = ТекСтрока;
      КонецЦикла;
            
КонецПроцедуры

Ответили: пост №2
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №2
 
13.10.2017 10:00
Ответ на пост №1

Илья Привалов, так у тебя ТекстПисьма каждый раз перезаписывается текущей строкой из файла.

Илья Привалов
читатель
офлайн
Дата регистрации: 13.10.2017
Сообщений: 13
Пост №3
 
13.10.2017 10:06

Prikum пишет:

Цитата

                              
                                     Илья Привалов , так у тебя ТекстПисьма каждый раз перезаписывается текущей строкой из файла.
                                                            ­      
Я понимаю, подскажите будьте добры, каким образом мне каждую строку выводить? Или может все можно сделать проще и не к строке обращаться, а сразу из файла в поле ввода поместить, пробовал методом ПРОЧИТАТЬ, но как оказалось у поля ввода такого метода нет..

Ответили: пост №4
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №4
 
13.10.2017 10:08
Ответ на пост №3

Илья Привалов, какой тип у поля ввода?

Ответили: пост №5
Илья Привалов
читатель
офлайн
Дата регистрации: 13.10.2017
Сообщений: 13
Пост №5
 
13.10.2017 10:13
Ответ на пост №4

Prikum, Строка с неограниченной длинной.

Ответили: пост №6 , пост №7
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №6
 
13.10.2017 10:30
Ответ на пост №5

Илья Привалов,

Код
ТекстПисьма = Текст.ПолучитьТекст(); 

Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №7
 
13.10.2017 10:31
Ответ на пост №5

Илья Привалов, только цикл убери.

Илья Привалов
читатель
офлайн
Дата регистрации: 13.10.2017
Сообщений: 13
Пост №8
 
13.10.2017 11:18

Большое спасибо, все работает)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги