Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Не могу найти настройку в режиме управляемого интерфейса.

Ciklon
читатель
офлайн
Дата регистрации: 01.02.2011
Сообщений: 6
Пост №1
 
10.02.2011 10:41

Как в любой конфигурации, работающей в режиме управляемого интерфейса (УТ, УНФ, БСП) задать настройку, чтобы при выходе из программы запрашивало подтверждение на выход, а не захлопывалось по ошибочному нажатию?

Ciklon
читатель
офлайн
Дата регистрации: 01.02.2011
Сообщений: 6
Пост №2
 
10.02.2011 12:31

Задать настройку, чтобы при закрытии приложения запрашивало подтверждение на выход из программы, в принципе возможно в управляемом интерфейсе?

ПСВ
читатель
офлайн
Дата регистрации: 06.04.2009
Сообщений: 379
Пост №3
 
10.02.2011 13:50

"Программист?<br><br>Из Документооборота:<br><br>Процедура ПередЗавершениемРаботыСистемы(Отказ)<br> <br> ЗапрашиватьПодтверждениеПриЗакрытииПрограммы = РаботаСПрограммой.ПолучитьЗапросРазрешенияНаВыходИзПрограммы();<br> Если ЗапрашиватьПодтверждениеПриЗакрытииПрограммы = Истина Тогда<br> Результат = Вопрос(НСтр("ru = 'Выйти из программы?'"), РежимДиалогаВопрос.ДаНет);<br> Если Результат <> КодВозвратаДиалога.Да Тогда<br> Отказ = Истина;<br> Возврат;<br> КонецЕсли; <br> КонецЕсли;<br> <br> // РаботаСФайлами<br> ПоказыватьЗанятыеФайлыПриЗавершенииРаботы = ФайловыеФункцииКлиентПовтИсп.ПолучитьПерсональныеНастройкиРаботыСФайлами().ПоказыватьЗанятыеФайлыПриЗавершенииРаботы;<br> Если ПоказыватьЗанятыеФайлыПриЗавершенииРаботы Тогда <br> РаботаСФайламиКлиент.ПоказатьЗанятыеФайлыПриЗавершенииРаботы(Отказ);<br> КонецЕсли; <br> // Конец РаботаСФайлами<br> <br>КонецПроцедуры<br>"

Ciklon
читатель
офлайн
Дата регистрации: 01.02.2011
Сообщений: 6
Пост №4
 
10.02.2011 14:23

Спасибо за готовность помочь, но я наверно недостаточно четко описал чего я хочу. Если не стоит задача как можно скорее снять замки в конфигураторе и подсадить пользователя на свои "услуги", как включить эту настройку из пользовательского режима? В 8.1 была настройка: Сервис - настройки пользователя - другие настройки - запрашивать подтверждение при закрытии программы. Аналог такой настройки в режиме управляемого интерфейса хотя бы в принципе существует?

Дина
читатель
офлайн
Дата регистрации: 21.05.2010
Сообщений: 2981
Пост №5
 
10.02.2011 15:16

Если я правильно Вас поняла, то нашла в "Справке", что похоже делать это можно только в обычном режиме.<br>"Справочник «Пользователи» предназначен для хранения списка пользователей. В основном это пользователи, работающие с конфигурацией (пользователи ИБ).<br>..........<br>Дополнительные сведения <br><br>Редактирование дополнительных сведений выполняется через подменю "Дополнительные сведения".<br><br>Дополнительные сведения доступны только в обычном приложении.<br><br> *Настройки пользователя - позволяет изменить настройки пользователя<br> *Контактная информация - позволяет изменить контактную информацию, которая используется при работе пользователя с клиентами и при работе со встроенной электронной почтой <br> *Группы пользователя - позволяет изменить группы, в которые входит пользователь<br> *Дополнительные права - позволяет изменить дополнительные права пользователя"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С