Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

В стаже не выделяються больничные листы и отпуска за свой счет(Комплексная 7.7)

aimerlive
читатель
офлайн
Дата регистрации: 08.04.2010
Сообщений: 67
Пост №1
 
19.01.2011 12:34

При выгрузке из 1с Комплексная 7.7 в стаже не выделяются больничные листы и отпуска за свой счет.

VVP
читатель
офлайн
Дата регистрации: 12.10.2006
Сообщений: 4950
Пост №2
 
19.01.2011 13:44

При выгрузке чего и куда?

aimerlive
читатель
офлайн
Дата регистрации: 08.04.2010
Сообщений: 67
Пост №3
 
19.01.2011 14:08

Отчет: Подготовка сведений для ПФР. При выгрузке пачек в файл. Суммы берет правильно а вот стажевые интервалы не правильно. Получается что у нас люди не болели и отпуска за свой счет не брали.

VVP
читатель
офлайн
Дата регистрации: 12.10.2006
Сообщений: 4950
Пост №4
 
19.01.2011 17:34

Проверь справочник Сотрудники - Нужный сотрудник. Открываешь. Кнопка Ввод даных - Песонифицированый учет.

aimerlive
читатель
офлайн
Дата регистрации: 08.04.2010
Сообщений: 67
Пост №5
 
20.01.2011 09:29

"По кнопке персонифицированный учет тоже ничего не заполнялось.<br> Нашла ошибку в функции глЗаполнитьТаблицуПериодовДействияВР. В цикле идет перебор всегда первый месяц в массиве дней. И не учитывалось что в массиве целый год.<br> Но пока не удается выделять период с отпуском до 3х лет. Может у кого есть какие соображения как это исправить? <br><br>Функция глЗаполнитьТаблицуПериодовДействияВР(Сотрудник,ТаблицаПериодов,НачалоПериода, ОкончаниеПериода, СписокВР)<br> <br> Перем МассивДней[370];<br> <br> ТаблицаПериодов=СоздатьОбъект("ТаблицаЗначений"); <br> ТаблицаПериодов.НоваяКолонка("НачалоПериода");<br> ТаблицаПериодов.НоваяКолонка("ОкончаниеПериода");<br> <br> Для Сч = 1 По 370 Цикл<br> МассивДней[Сч] = 1; <br> КонецЦикла; <br> <br> глЗаполнитьМассивДней(МассивДней, Сотрудник, НачалоПериода, ОкончаниеПериода, 0, СписокВР); <br> <br> КолДней = ОкончаниеПериода - НачалоПериода +1;<br> <br> ЕстьПериод=0;<br> Для Сч = 1 По КолДней Цикл <br> //Если (ЕстьПериод=0) и (МассивДней[Сч] = 0) Тогда //это было раньше<br> Если (ЕстьПериод=0) и (МассивДней[Сч+НомерДняГода(НачалоПериода)-1] = 0) Тогда //anna<br> ЕстьПериод=1;<br> ТаблицаПериодов.НоваяСтрока();<br> ТаблицаПериодов.НачалоПериода=НачалоПериода+Сч-1;<br>             //ИначеЕсли (ЕстьПериод=1) и (МассивДней[Сч] = 1) Тогда //это было раньше<br> ИначеЕсли (ЕстьПериод=1) и (МассивДней[Сч+НомерДняГода(НачалоПериода)-1] = 1) Тогда //anna<br> ЕстьПериод=0;<br> ТаблицаПериодов.ОкончаниеПериода=НачалоПериода+Сч-2;<br> КонецЕсли; <br> <br> КонецЦикла;<br> <br> Если ЕстьПериод=1 Тогда<br> //это значит, что в периоде который мы анализировали действие ВР не закончилось, <br> //установим дату окончания <br> ТаблицаПериодов.ОкончаниеПериода=ОкончаниеПериода;<br> КонецЕсли;<br> <br> Если ТаблицаПериодов.КоличествоСтрок()>0 Тогда<br> Возврат 1;<br> Иначе<br> Возврат 0;<br> КонецЕсли; <br> <br>КонецФункции //глЗаполнитьТаблицуПериодовДействияВР() <br>"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Представление регламентированной отчетности
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С