Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Работа со строками.

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №1
 
18.02.2010 11:07

Помогите решить задачку
есть строка "111111 аааааааа" как мне вытянуть из этой строки символы стоящие до первого пробела(111111), чтобы записать их в другую строку

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №2
 
18.02.2010 11:16

"Строка1 = "111111 аааааааа"
позиция = Найти(Строка1," ")
Если позиция > 0 Тогда
Строка2 = Лев(Строка1,позиция-1);
Иначе
Строка2 = Строка1;
КонецЕсли
"

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №3
 
18.02.2010 11:48

"ага получилось

Процедура Сформировать()
Спр=СоздатьОбъект("Справочник.Номенклатура");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
Строка1= Спр.Наименование;
позиция = Найти(Строка1," ");
Если позиция > 0 Тогда
Спр.Артикул = Лев(Строка1,позиция-1);
Иначе
Спр.Артикул = Строка1;
КонецЕсли;
Спр.Записать();
КонецЦикла;
КонецПроцедуры

А как добавить условие такого рода: обычно строки содержат в первой части до пробела символы состоящие из верхнего регистра, но есть строки содержащие в первой части до пробела символы состоящие из верхнего и нижнего регистра?
т.е. есть строка "ААААА ааааа" такие нужно обрабатывать, а бывают строки "Ааааа ааааа" и "ааааа ааааа" их ненужно обрабатывать, их нужно пропускать?"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
18.02.2010 11:54

"> ага получилось
>
> Процедура Сформировать()
> Спр=СоздатьОбъект("Справочник.Номенклатура");
> Спр.ВыбратьЭлементы();
> Пока Спр.ПолучитьЭлемент()=1 Цикл
> Строка1= Спр.Наименование;
> позиция = Найти(Строка1," ");
> Если позиция > 0 Тогда
> Спр.Артикул = Лев(Строка1,позиция-1);
> Иначе
> Спр.Артикул = Строка1;
> КонецЕсли;
> Спр.Записать();
> КонецЦикла;
> КонецПроцедуры

в выборке лучше не записывать !

> А как добавить условие такого рода: обычно строки содержат в первой части до пробела символы состоящие из верхнего регистра, но есть строки содержащие в первой части до пробела символы состоящие из верхнего и нижнего регистра?
> т.е. есть строка "ААААА ааааа" такие нужно обрабатывать, а бывают строки "Ааааа ааааа" и "ааааа ааааа" их ненужно обрабатывать, их нужно пропускать?

делай их все в нижний регистр и анализируй далее, т.е.

АнализируемаяСтрочка = "Ааааа ааааа";
Найти(НРег(АнализируемаяСтрочка ), "ааааа ааааа") будет отличное от 0 !

"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №5
 
18.02.2010 13:27

"> АнализируемаяСтрочка = "Ааааа ааааа";
> Найти(НРег(АнализируемаяСтрочка ), "ааааа ааааа") будет отличное от 0 !
>
Ему надо обработать те кто в верхнем регистре:
АнализируемаяСтрочка = "Ааааа"; //Эта будет пропущена
Если (ВРег(АнализируемаяСтрочка) = АнализируемаяСтрочка) Тогда
//Обрабатываем
КонецЕсли;
"

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №6
 
18.02.2010 16:49

спасибо все заработало как нужно

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №7
 
18.02.2010 17:09

"тогда всё в один регистр

АнализируемаяСтрочка = "Ааааа ааааа";
Найти(НРег(АнализируемаяСтрочка ), НРег("ааааа аАааа")) > 0"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги