Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Отчет по остаткам Комплексная 7.7, 496

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №1
 
25.03.2010 17:02

Есть задача вывести таблицу остатков тмц с датой последнего прихода каждой позиции, т.е. есть на складе количество товара = 50 состоящих из нескольких приходов, нужно в отчете вывести все эти 50 позиций и дату последнего прихода этого товара.
Может у кого есть уже написанный отчетик или помогите с чего начать?
заранее спс

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №2
 
25.03.2010 19:58

Учетная политика какая? FIFO, LIFO или "По средней"? Проще говоря, партионный учет есть?

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №3
 
26.03.2010 12:56

да партионный учет ведется

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №4
 
26.03.2010 17:26

"значит все просто, надо выполнить такой запрос и по его результатам сделать заполнение печатной формы:

ТекстЗапроса="Период с НужнаяДата по НужнаяДата;
             |Товар=Регистр.ПартииНаличие.Номенклатура;
             |ДатаПартии=Регистр.ПартииНаличие.Партия.ПриходныйДокумент.ДатаДок;
             |Функция ПоследняяДатаПоступления = Максимум(ДатаПартии);
             |Группировка Товар без групп упорядочить по Товар.Наименование;";

Запрос = СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
Пока Запрос.Группировка(1)=1 Цикл
       Сообщить(Строка(Запрос.Товар)+": "+Формат(Запрос.ПоследняяДатаПоступления,"ДДДММГГГГ"));
КонецЦикла;
КонецЕсли;"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №5
 
26.03.2010 17:38

Thorvardr
а измерения ДатаПартии когда заполняется ?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №6
 
26.03.2010 18:11

А оно там есть? Ну если есть, значит еще проще будет. Я просто в конфигурацию не заглядывал, когда ответ писал

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №7
 
29.03.2010 08:11

"Посмотрел я в конфигурацию, наверное, запрос должен быть таким:
ТекстЗапроса="Период с НужнаяДата по НужнаяДата;
            |Товар=Регистр.ПартииНаличие.Номенклатура;
            |ДатаПартии=Регистр.ПартииНаличие.ДатаПартии;
            |Количество=Регистр.ПартииНаличие.Количество;
            |Функция Остаток = КонОст(Количество);            
            |Функция ПоследняяДатаПоступления = Максимум(ДатаПартии);
            |Группировка Товар без групп упорядочить по Товар.Наименование;";"

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №8
 
06.05.2010 11:46

чет не выходит, в ПоследняяДатаПоступления ничего не показывает...отладчик говорит неправильное выражение...

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №9
 
06.05.2010 13:24

"А у меня работает, только Макс(ДатаПартии) в результате дает выражение, приведенное к числовому. Приходится его снова в Дату принудительно:

Процедура Сформировать()
НужнаяДата=ТекущаяДата();
ТекстЗапроса="Период с НужнаяДата по НужнаяДата;
       |Товар=Регистр.ПартииНаличие.Номенклатура;
       |ДатаПартии=Регистр.ПартииНаличие.ДатаПартии;
       |Количество=Регистр.ПартииНаличие.Количество;
       |Функция Остаток = КонОст(Количество);            
       |Функция ПоследняяДатаПоступления = Максимум(ДатаПартии);
       |Группировка Товар без групп упорядочить по Товар.Наименование;";

Запрос=СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
Пока Запрос.Группировка(1)=1 Цикл
Сообщить(Строка(Запрос.Товар)+" "+Строка(Запрос.Остаток)+" "+СокрЛП(Дата(Запрос.ПоследняяДатаПоступления)));
КонецЦикла;
КонецЕсли;

КонецПроцедуры"

MaxTi
читатель
офлайн
Дата регистрации: 10.02.2010
Сообщений: 52
Пост №10
 
13.05.2010 15:54

нет все равно не выводит дату... вместо нее пусто, только точки форматные стоят и все. может что-то должно быть какое-нибудь условие или у меня что-то не заполнено?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги