Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Балансовый счет не может корреспондировать с пустым счетом!

Ant_S
читатель
офлайн
Дата регистрации: 29.03.2010
Сообщений: 2
Пост №1
 
29.03.2010 12:35

"Здраствуйте всем!!! Подскажите пожалуйста ни как не могу допетрить!!!
В авансовомОтчете делаем проводку на 26 счет , два субконто: Общехоз. затраты и Подразделения выбираем значение из этих справочеиков жмем провести и вылазиет ошибка ( Балансовый счет не может корреспондировать с пустым счетом!) а если не вводить первое субконто (Общехоз. затраты)документ проводится без проблем!!! Подскажите как выйти из ситуации и решить эту проблему хотябу подскажите где копать????

а могут ли это быть проблемы с забалансовыми счетами???

может модуль проведения поможет дать мне ответ Заранее спасибо!!!!

Процедура УСН()
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
      
       Если ДокументПоставки.Выбран()=1 Тогда
            Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
             ДокументПоставки.ВыбратьСтроки();
             Пока ДокументПоставки.ПолучитьСтроку()=1 Цикл
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет = СчетПоКоду("У.05");
                   Операция.Дебет.Контрагенты = ДокументПоставки.Контрагент;
                   Операция.Дебет.Материалы= ДокументПоставки.Материал;
                   Операция.Кредит.Счет = СчетПоКоду("У.01");
                   Операция.Кредит.Контрагенты = ДокументПоставки.Контрагент;
                   Операция.Кредит.Материалы= ДокументПоставки.Материал;
                   Операция.Количество = ДокументПоставки.Количество;
                   Операция.Сумма = ДокументПоставки.Сумма;
                   Операция.СодержаниеПроводки = "Оплачено сырье";
                   Операция.НомерЖурнала = "УСН";
                  
                   Если ДокументПоставки.НДС>0 Тогда
                        Операция.НоваяПроводка();
                        Операция.Дебет.Счет = СчетПоКоду("У.03");
                        Операция.Кредит.Счет = СчетПоКоду("У.02");
                        Операция.Сумма = ДокументПоставки.НДС;
                        Операция.СодержаниеПроводки = "Списываем НДС";
                        Операция.НомерЖурнала = "УСН";
                        Операция.ПервичныйДокумент =Формат(ДокументПоставки.ДатаДокВходящий, "Д ДДММГГГГ")+", №"+ДокументПоставки.НомерДокВходящий;
                   КонецЕсли;
                  
             КонецЦикла;
             Операция.Записать();
            КонецЕсли;
            Док=СоздатьОбъект("Документ");
            Док.НайтиДокумент(ДокументПоставки);
            Док.ОплатаДок=1;
            Док.Записать();
            Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
             //Если ДокументПоставки.Итог("НДС")>0 Тогда

                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("У04");
                   Операция.СодержаниеПроводки="Отражен факт расхода";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=Сумма;                  
            // КонецЕсли;

            ИначеЕсли КоррСчет<>СчетПоКоду("51") Тогда
             Операция.НоваяПроводка();
             Операция.Дебет.Счет=СчетПоКоду("У04");
             Операция.СодержаниеПроводки="Отражен факт расхода";
             Операция.НомерЖурнала="НУ";      
             Операция.Сумма=Сумма;
            КонецЕсли;
            Если ДокументПоставки.Вид()="УслугиСтороннихОрганизаций" Тогда
             Если ДокументПоставки.Итог("НДС")>0 Тогда
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("НДС");
                   Операция.Дебет.Контрагенты=Субконто1;
                   Операция.Дебет.Договоры=Субконто2;
                   Операция.СодержаниеПроводки="НДС";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=ДокументПоставки.Итог("НДС");
             КонецЕсли;
            КонецЕсли;
       ИначеЕсли (КоррСчет<>СчетПоКоду("51")) И (КоррСчет<>СчетПоКоду("66.3")) И (КоррСчет<>СчетПоКоду("71.1")) Тогда
            Операция.НоваяПроводка();
            Операция.Дебет.Счет=СчетПоКоду("У04");
            Операция.СодержаниеПроводки="Отражен факт расхода";
            Операция.НомерЖурнала="НУ";      
            Операция.Сумма=Сумма;                  
       КонецЕсли;      
       Если УчитыватьДляНУ=1 Тогда
            //Если ДвижениеДенежныхСредств.Наименование="Оплата за основные средства" Тогда

            // Если КоррСчет=СчетПоКоду("60.1") Тогда

            //       Если ДокументПоставки.Выбран()=0 Тогда

            //            Предупреждение("Не выбран документ поставки");

            //            СтатусВозврата(0);

            //            Возврат;

            //       КонецЕсли;

            //       Если ДокументПоставки.КоличествоСтрок()>1 Тогда

            //            Предупреждение("В документе поставки должно быть поступление одного ОС");

            //            СтатусВозврата(0);

            //            Возврат;

            //       КонецЕсли;

            //       ОснСр=СоздатьОбъект("Справочник.ОсновныеСредства");

            //       ДокументПоставки.ВыбратьСтроки();

            //       ДокументПоставки.ПолучитьСтроку();            

            //       ОснСр.НайтиЭлемент(ДокументПоставки.ОбъектВнеоборотныхАктивов);

            //       ОснСр.Оплата.Установить(ДатаДок,Сумма);

            //       ОснСр.Записать();

            //       Операция.НоваяПроводка();

            //       Операция.Дебет.Счет=СчетПоКоду("У02.1");

            //      

            //       Операция.Дебет.ОсновныеСредства=ДокументПоставки.ОбъектВнеоборотныхАктивов;

            //       Операция.Дебет.ДатыОплаты=ДатаДок;

            //       Операция.СодержаниеПроводки="Учтена оплата основных средств";

            //       Операция.НомерЖурнала="НУ";      

            //       Операция.Сумма=Сумма;

            // КонецЕсли;

            //Иначе

             Если (КоррСчет=СчетПоКоду("60.1")) И (ДокументПоставки.Выбран()=1) Тогда
                   Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
                        Если ДокументПоставки.Итог("НДС")>0 Тогда
                         Операция.НоваяПроводка();
                         Операция.Дебет.Счет=СчетПоКоду("У02.2");
                         Операция.СодержаниеПроводки="Учтен расход: НДС по поступившему сырью";
                         Операция.НомерЖурнала="НУ";      
                         Операция.Сумма=ДокументПоставки.Итог("НДС");                  
                        КонецЕсли;
                   Иначе
                        Операция.НоваяПроводка();
                        Операция.Дебет.Счет=СчетПоКоду("У02.2");
                        Операция.СодержаниеПроводки="Учтен расход";
                        Операция.НомерЖурнала="НУ";      
                        Операция.Сумма=Сумма;
                   КонецЕсли;
             Иначе
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("У02.2");
                   Операция.СодержаниеПроводки="Учтен расход";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=Сумма;
             КонецЕсли;
            //КонецЕсли;

       КонецЕсли;
КонецЦикла;
Операция.Записать();
КонецПроцедуры
//____________________________________­_________________________________________

Процедура ОбработкаПроведения()
УСН();
ТипОтчета = Валюта.Выбран() + 1;
Сч19 = СчетПоКоду("19.3");

Если ДокументПоставки.Выбран()=1 Тогда
       Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
            ДокументПоставки.ВыбратьСтроки();
            Пока ДокументПоставки.ПолучитьСтроку()=1 Цикл
             Операция.НоваяПроводка();
             Операция.Дебет.Счет = СчетПоКоду("У.05");
             Операция.Дебет.Контрагенты = ДокументПоставки.Контрагент;
             Операция.Дебет.Материалы= ДокументПоставки.Материал;
             Операция.Кредит.Счет = СчетПоКоду("У.01");
             Операция.Кредит.Контрагенты = ДокументПоставки.Контрагент;
             Операция.Кредит.Материалы= ДокументПоставки.Материал;
             Операция.Количество = ДокументПоставки.Количество;
             Операция.Сумма = ДокументПоставки.Сумма;
             Операция.СодержаниеПроводки = "Оплачено сырье";
             Операция.НомерЖурнала = "УСН";
            
             Если ДокументПоставки.НДС>0 Тогда
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет = СчетПоКоду("У.03");
                   Операция.Кредит.Счет = СчетПоКоду("У.02");
                   Операция.Сумма = ДокументПоставки.НДС;
                   Операция.СодержаниеПроводки = "Списываем НДС";
                   Операция.НомерЖурнала = "УСН";
                   Операция.ПервичныйДокумент =Формат(ДокументПоставки.ДатаДокВходящий, "Д ДДММГГГГ")+", №"+ДокументПоставки.НомерДокВходящий;
             КонецЕсли;
            
            КонецЦикла;
            Операция.Записать();
       КонецЕсли;
КонецЕсли;
Если ТипОтчета = 2 Тогда
            Сч71 = СчетПоКоду("71.11");

       КурсВал = Валюта.Курс.Получить(ДатаДок);
       Кратность = Валюта.Кратность.Получить(ДатаДок);
       Кратность = ?(Кратность=0,1,Кратность);

       глТаблицаСчетов.УдалитьСтроки();
       глТаблицаСчетов.НоваяСтрока();
       глТаблицаСчетов.Счет = Сч71;
       глТаблицаСчетов.Субконто1 = Сотрудник;
       глТаблицаСчетов.Субконто2 = """";
       глТаблицаСчетов.Субконто3 = """";
       глТаблицаСчетов.Валюта = Валюта;
       глПереоценкаСчетов(Контекст, глТаблицаСчетов);

Иначе
       Сч71 = СчетПоКоду("71.1");
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
       Если ПустоеЗначение(КоррСчет) = 1 Тогда
            ТекстСообщения = "В строке №" + НомерСтроки + " не указан корреспондирующий счет.";
            глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1);
            глНеПроводить(ТекущийДокумент());
            Возврат;
            
       ИначеЕсли КоррСчет.Валютный = 1 Тогда
            ТекстСообщения = "В строке №" + НомерСтроки + " корреспондирующий счет не может быть валютным.";
            глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1);
            глНеПроводить(ТекущийДокумент());
            Возврат;
       КонецЕсли;

       Операция.НоваяПроводка();
       Операция.НомерЖурнала = "БК";
       Операция.СодержаниеПроводки = КомуЗаЧто;
       Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
       Операция.Дебет.Счет = КоррСчет;
       Сообщить ("КоррСчет это: "+ КоррСчет);
       Операция.Дебет.Субконто(1,Субконто1);
       Операция.Дебет.Субконто(2,Субконто2);
       Операция.Дебет.Субконто(3,Субконто3);
       Операция.Кредит.Счет = Сч71;
       Операция.Кредит.Сотрудники = Сотрудник;

       Если НДС > 0 Тогда
            Если ТипОтчета = 1 Тогда
             Операция.Сумма = Сумма - НДС;
            Иначе
             Операция.Сумма = Окр(Сумма*КурсВал/Кратность,2,1) - Окр(НДС*КурсВал/Кратность,2,1);
            КонецЕсли;
       Иначе
            Если ТипОтчета = 1 Тогда
             Операция.Сумма = Сумма;
            Иначе
             Операция.Сумма = Окр(Сумма*КурсВал/Кратность,2,1);
            КонецЕсли;
       КонецЕсли;

       Если КоррСчет.Количественный = 1 Тогда
            Операция.Количество = Количество;
       КонецЕсли;

       Если ТипОтчета = 2 Тогда
            Операция.Валюта = Валюта;
            Операция.ВалСумма = Сумма - НДС;
       КонецЕсли;
      
       // Отражение операций в налоговом учете.

       ОбъектыАналитикиНУ = глСчетИАналитикаРасходовНУ(Контекст, КоррСчет, Субконто1, Субконто2, Субконто3);
      
       // Если опредлен налоговый счет, то необходимо

       // сформировать проводку для целей налогового учета.

       СчетНУ = ОбъектыАналитикиНУ.Получить("Счет");
       Если ПустоеЗначение(СчетНУ) = 0 Тогда
            СуммаРасходов = Операция.Сумма;
            
            Операция.НоваяПроводка();
            Операция.НомерЖурнала = "НУ";
            Операция.СодержаниеПроводки = КомуЗаЧто;
            Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
            Операция.Дебет.Счет = СчетНУ;
            Для СчетчикЦикла = 1 По СчетНУ.КоличествоСубконто() Цикл
             ИдентификаторСубконто = СчетНУ.ВидСубконто(СчетчикЦикла,,).Идентификатор();
             Операция.Дебет.Субконто(СчетчикЦикла, ОбъектыАналитикиНУ.Получить(ИдентификаторСубконто));
            КонецЦикла;
            
            Операция.Дебет.Субконто(ВидыСубконто.УсловияПоступленияИВыбытия, Перечисление.УсловияПоступленияИВыбытия.Другие);
            
            Операция.Сумма = СуммаРасходов;
            Если СчетНУ.Количественный = 1 Тогда
             Операция.Количество = Количество;
            КонецЕсли;
       КонецЕсли;
КонецЦикла;

Операция.Записать();

ТекстСообщения = "Сотруднику "+Сотрудник+" зачтена сумма, выданная под отчет.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);

ТекстСообщения = "Документ проведен.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);
глПриПроведении(ТекущийДокумент());

КонецПроцедуры"

Jetta
читатель
офлайн
Дата регистрации: 02.04.2010
Сообщений: 16
Пост №2
 
03.04.2010 23:09

Речь, как я понимаю, про 1С:УСН? У меня этой конфы под рукой нет (да и не приходилось мне с ней разбираться), но я бы искала так: поскольку текста "Балансовый счет не может корреспондировать с пустым счетом" в модуле проведения не видать, я бы запустила глобальный поиск этого текста. Скорее всего, он отыщется в глоб.модуле. Почитать найденный кусок, а если не станет ясно, попробовать в отладчике поставить туда точку останова и посмотреть, из-за чего срабатывает эта ветка.

Dissar
читатель
офлайн
Дата регистрации: 21.01.2010
Сообщений: 58
Пост №3
 
09.04.2010 09:05

У меня такая же ошибка в общехозяйственной бухгалтерии 7.7, релиз 514.

Что делать?

Jetta
читатель
офлайн
Дата регистрации: 02.04.2010
Сообщений: 16
Пост №4
 
09.04.2010 10:32

Не знаю, как это может быть! Поискала указанную строку в последних конфигурациях УСН и Бухгалтерии - отыскалось в совершенно посторонних обработках переноса операций и загрузки данных. Вроде никакой связи с аванс.отчетом не просматривается. В этой ситуации ничего, кроме пошаговой проверки в отладчике, посоветовать не могу.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги