Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Балансовый счет не может корреспондировать с пустым счетом!
Ant_S
Пост №1
Ant_S
читатель
офлайн
Дата регистрации: 29.03.2010
Сообщений: 2
Пост №1
 
29.03.2010 12:35

"Здраствуйте всем!!! Подскажите пожалуйста ни как не могу допетрить!!!
В авансовомОтчете делаем проводку на 26 счет , два субконто: Общехоз. затраты и Подразделения выбираем значение из этих справочеиков жмем провести и вылазиет ошибка ( Балансовый счет не может корреспондировать с пустым счетом!) а если не вводить первое субконто (Общехоз. затраты)документ проводится без проблем!!! Подскажите как выйти из ситуации и решить эту проблему хотябу подскажите где копать????

а могут ли это быть проблемы с забалансовыми счетами???

может модуль проведения поможет дать мне ответ Заранее спасибо!!!!

Процедура УСН()
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
      
       Если ДокументПоставки.Выбран()=1 Тогда
            Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
             ДокументПоставки.ВыбратьСтроки();
             Пока ДокументПоставки.ПолучитьСтроку()=1 Цикл
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет = СчетПоКоду("У.05");
                   Операция.Дебет.Контрагенты = ДокументПоставки.Контрагент;
                   Операция.Дебет.Материалы= ДокументПоставки.Материал;
                   Операция.Кредит.Счет = СчетПоКоду("У.01");
                   Операция.Кредит.Контрагенты = ДокументПоставки.Контрагент;
                   Операция.Кредит.Материалы= ДокументПоставки.Материал;
                   Операция.Количество = ДокументПоставки.Количество;
                   Операция.Сумма = ДокументПоставки.Сумма;
                   Операция.СодержаниеПроводки = "Оплачено сырье";
                   Операция.НомерЖурнала = "УСН";
                  
                   Если ДокументПоставки.НДС>0 Тогда
                        Операция.НоваяПроводка();
                        Операция.Дебет.Счет = СчетПоКоду("У.03");
                        Операция.Кредит.Счет = СчетПоКоду("У.02");
                        Операция.Сумма = ДокументПоставки.НДС;
                        Операция.СодержаниеПроводки = "Списываем НДС";
                        Операция.НомерЖурнала = "УСН";
                        Операция.ПервичныйДокумент =Формат(ДокументПоставки.ДатаДокВходящий, "Д ДДММГГГГ")+", №"+ДокументПоставки.НомерДокВходящий;
                   КонецЕсли;
                  
             КонецЦикла;
             Операция.Записать();
            КонецЕсли;
            Док=СоздатьОбъект("Документ");
            Док.НайтиДокумент(ДокументПоставки);
            Док.ОплатаДок=1;
            Док.Записать();
            Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
             //Если ДокументПоставки.Итог("НДС")>0 Тогда

                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("У04");
                   Операция.СодержаниеПроводки="Отражен факт расхода";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=Сумма;                  
            // КонецЕсли;

            ИначеЕсли КоррСчет<>СчетПоКоду("51") Тогда
             Операция.НоваяПроводка();
             Операция.Дебет.Счет=СчетПоКоду("У04");
             Операция.СодержаниеПроводки="Отражен факт расхода";
             Операция.НомерЖурнала="НУ";      
             Операция.Сумма=Сумма;
            КонецЕсли;
            Если ДокументПоставки.Вид()="УслугиСтороннихОрганизаций" Тогда
             Если ДокументПоставки.Итог("НДС")>0 Тогда
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("НДС");
                   Операция.Дебет.Контрагенты=Субконто1;
                   Операция.Дебет.Договоры=Субконто2;
                   Операция.СодержаниеПроводки="НДС";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=ДокументПоставки.Итог("НДС");
             КонецЕсли;
            КонецЕсли;
       ИначеЕсли (КоррСчет<>СчетПоКоду("51")) И (КоррСчет<>СчетПоКоду("66.3")) И (КоррСчет<>СчетПоКоду("71.1")) Тогда
            Операция.НоваяПроводка();
            Операция.Дебет.Счет=СчетПоКоду("У04");
            Операция.СодержаниеПроводки="Отражен факт расхода";
            Операция.НомерЖурнала="НУ";      
            Операция.Сумма=Сумма;                  
       КонецЕсли;      
       Если УчитыватьДляНУ=1 Тогда
            //Если ДвижениеДенежныхСредств.Наименование="Оплата за основные средства" Тогда

            // Если КоррСчет=СчетПоКоду("60.1") Тогда

            //       Если ДокументПоставки.Выбран()=0 Тогда

            //            Предупреждение("Не выбран документ поставки");

            //            СтатусВозврата(0);

            //            Возврат;

            //       КонецЕсли;

            //       Если ДокументПоставки.КоличествоСтрок()>1 Тогда

            //            Предупреждение("В документе поставки должно быть поступление одного ОС");

            //            СтатусВозврата(0);

            //            Возврат;

            //       КонецЕсли;

            //       ОснСр=СоздатьОбъект("Справочник.ОсновныеСредства");

            //       ДокументПоставки.ВыбратьСтроки();

            //       ДокументПоставки.ПолучитьСтроку();            

            //       ОснСр.НайтиЭлемент(ДокументПоставки.ОбъектВнеоборотныхАктивов);

            //       ОснСр.Оплата.Установить(ДатаДок,Сумма);

            //       ОснСр.Записать();

            //       Операция.НоваяПроводка();

            //       Операция.Дебет.Счет=СчетПоКоду("У02.1");

            //      

            //       Операция.Дебет.ОсновныеСредства=ДокументПоставки.ОбъектВнеоборотныхАктивов;

            //       Операция.Дебет.ДатыОплаты=ДатаДок;

            //       Операция.СодержаниеПроводки="Учтена оплата основных средств";

            //       Операция.НомерЖурнала="НУ";      

            //       Операция.Сумма=Сумма;

            // КонецЕсли;

            //Иначе

             Если (КоррСчет=СчетПоКоду("60.1")) И (ДокументПоставки.Выбран()=1) Тогда
                   Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
                        Если ДокументПоставки.Итог("НДС")>0 Тогда
                         Операция.НоваяПроводка();
                         Операция.Дебет.Счет=СчетПоКоду("У02.2");
                         Операция.СодержаниеПроводки="Учтен расход: НДС по поступившему сырью";
                         Операция.НомерЖурнала="НУ";      
                         Операция.Сумма=ДокументПоставки.Итог("НДС");                  
                        КонецЕсли;
                   Иначе
                        Операция.НоваяПроводка();
                        Операция.Дебет.Счет=СчетПоКоду("У02.2");
                        Операция.СодержаниеПроводки="Учтен расход";
                        Операция.НомерЖурнала="НУ";      
                        Операция.Сумма=Сумма;
                   КонецЕсли;
             Иначе
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("У02.2");
                   Операция.СодержаниеПроводки="Учтен расход";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=Сумма;
             КонецЕсли;
            //КонецЕсли;

       КонецЕсли;
КонецЦикла;
Операция.Записать();
КонецПроцедуры
//____________________________________­_________________________________________

Процедура ОбработкаПроведения()
УСН();
ТипОтчета = Валюта.Выбран() + 1;
Сч19 = СчетПоКоду("19.3");

Если ДокументПоставки.Выбран()=1 Тогда
       Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
            ДокументПоставки.ВыбратьСтроки();
            Пока ДокументПоставки.ПолучитьСтроку()=1 Цикл
             Операция.НоваяПроводка();
             Операция.Дебет.Счет = СчетПоКоду("У.05");
             Операция.Дебет.Контрагенты = ДокументПоставки.Контрагент;
             Операция.Дебет.Материалы= ДокументПоставки.Материал;
             Операция.Кредит.Счет = СчетПоКоду("У.01");
             Операция.Кредит.Контрагенты = ДокументПоставки.Контрагент;
             Операция.Кредит.Материалы= ДокументПоставки.Материал;
             Операция.Количество = ДокументПоставки.Количество;
             Операция.Сумма = ДокументПоставки.Сумма;
             Операция.СодержаниеПроводки = "Оплачено сырье";
             Операция.НомерЖурнала = "УСН";
            
             Если ДокументПоставки.НДС>0 Тогда
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет = СчетПоКоду("У.03");
                   Операция.Кредит.Счет = СчетПоКоду("У.02");
                   Операция.Сумма = ДокументПоставки.НДС;
                   Операция.СодержаниеПроводки = "Списываем НДС";
                   Операция.НомерЖурнала = "УСН";
                   Операция.ПервичныйДокумент =Формат(ДокументПоставки.ДатаДокВходящий, "Д ДДММГГГГ")+", №"+ДокументПоставки.НомерДокВходящий;
             КонецЕсли;
            
            КонецЦикла;
            Операция.Записать();
       КонецЕсли;
КонецЕсли;
Если ТипОтчета = 2 Тогда
            Сч71 = СчетПоКоду("71.11");

       КурсВал = Валюта.Курс.Получить(ДатаДок);
       Кратность = Валюта.Кратность.Получить(ДатаДок);
       Кратность = ?(Кратность=0,1,Кратность);

       глТаблицаСчетов.УдалитьСтроки();
       глТаблицаСчетов.НоваяСтрока();
       глТаблицаСчетов.Счет = Сч71;
       глТаблицаСчетов.Субконто1 = Сотрудник;
       глТаблицаСчетов.Субконто2 = """";
       глТаблицаСчетов.Субконто3 = """";
       глТаблицаСчетов.Валюта = Валюта;
       глПереоценкаСчетов(Контекст, глТаблицаСчетов);

Иначе
       Сч71 = СчетПоКоду("71.1");
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
       Если ПустоеЗначение(КоррСчет) = 1 Тогда
            ТекстСообщения = "В строке №" + НомерСтроки + " не указан корреспондирующий счет.";
            глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1);
            глНеПроводить(ТекущийДокумент());
            Возврат;
            
       ИначеЕсли КоррСчет.Валютный = 1 Тогда
            ТекстСообщения = "В строке №" + НомерСтроки + " корреспондирующий счет не может быть валютным.";
            глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1);
            глНеПроводить(ТекущийДокумент());
            Возврат;
       КонецЕсли;

       Операция.НоваяПроводка();
       Операция.НомерЖурнала = "БК";
       Операция.СодержаниеПроводки = КомуЗаЧто;
       Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
       Операция.Дебет.Счет = КоррСчет;
       Сообщить ("КоррСчет это: "+ КоррСчет);
       Операция.Дебет.Субконто(1,Субконто1);
       Операция.Дебет.Субконто(2,Субконто2);
       Операция.Дебет.Субконто(3,Субконто3);
       Операция.Кредит.Счет = Сч71;
       Операция.Кредит.Сотрудники = Сотрудник;

       Если НДС > 0 Тогда
            Если ТипОтчета = 1 Тогда
             Операция.Сумма = Сумма - НДС;
            Иначе
             Операция.Сумма = Окр(Сумма*КурсВал/Кратность,2,1) - Окр(НДС*КурсВал/Кратность,2,1);
            КонецЕсли;
       Иначе
            Если ТипОтчета = 1 Тогда
             Операция.Сумма = Сумма;
            Иначе
             Операция.Сумма = Окр(Сумма*КурсВал/Кратность,2,1);
            КонецЕсли;
       КонецЕсли;

       Если КоррСчет.Количественный = 1 Тогда
            Операция.Количество = Количество;
       КонецЕсли;

       Если ТипОтчета = 2 Тогда
            Операция.Валюта = Валюта;
            Операция.ВалСумма = Сумма - НДС;
       КонецЕсли;
      
       // Отражение операций в налоговом учете.

       ОбъектыАналитикиНУ = глСчетИАналитикаРасходовНУ(Контекст, КоррСчет, Субконто1, Субконто2, Субконто3);
      
       // Если опредлен налоговый счет, то необходимо

       // сформировать проводку для целей налогового учета.

       СчетНУ = ОбъектыАналитикиНУ.Получить("Счет");
       Если ПустоеЗначение(СчетНУ) = 0 Тогда
            СуммаРасходов = Операция.Сумма;
            
            Операция.НоваяПроводка();
            Операция.НомерЖурнала = "НУ";
            Операция.СодержаниеПроводки = КомуЗаЧто;
            Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
            Операция.Дебет.Счет = СчетНУ;
            Для СчетчикЦикла = 1 По СчетНУ.КоличествоСубконто() Цикл
             ИдентификаторСубконто = СчетНУ.ВидСубконто(СчетчикЦикла,,).Идентификатор();
             Операция.Дебет.Субконто(СчетчикЦикла, ОбъектыАналитикиНУ.Получить(ИдентификаторСубконто));
            КонецЦикла;
            
            Операция.Дебет.Субконто(ВидыСубконто.УсловияПоступленияИВыбытия, Перечисление.УсловияПоступленияИВыбытия.Другие);
            
            Операция.Сумма = СуммаРасходов;
            Если СчетНУ.Количественный = 1 Тогда
             Операция.Количество = Количество;
            КонецЕсли;
       КонецЕсли;
КонецЦикла;

Операция.Записать();

ТекстСообщения = "Сотруднику "+Сотрудник+" зачтена сумма, выданная под отчет.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);

ТекстСообщения = "Документ проведен.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);
глПриПроведении(ТекущийДокумент());

КонецПроцедуры"

 
Ant_S
Пост №1
29.03.2010 12:35
 

"Здраствуйте всем!!! Подскажите пожалуйста ни как не могу допетрить!!!
В авансовомОтчете делаем проводку на 26 счет , два субконто: Общехоз. затраты и Подразделения выбираем значение из этих справочеиков жмем провести и вылазиет ошибка ( Балансовый счет не может корреспондировать с пустым счетом!) а если не вводить первое субконто (Общехоз. затраты)документ проводится без проблем!!! Подскажите как выйти из ситуации и решить эту проблему хотябу подскажите где копать????

а могут ли это быть проблемы с забалансовыми счетами???

может модуль проведения поможет дать мне ответ Заранее спасибо!!!!

Процедура УСН()
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
      
       Если ДокументПоставки.Выбран()=1 Тогда
            Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
             ДокументПоставки.ВыбратьСтроки();
             Пока ДокументПоставки.ПолучитьСтроку()=1 Цикл
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет = СчетПоКоду("У.05");
                   Операция.Дебет.Контрагенты = ДокументПоставки.Контрагент;
                   Операция.Дебет.Материалы= ДокументПоставки.Материал;
                   Операция.Кредит.Счет = СчетПоКоду("У.01");
                   Операция.Кредит.Контрагенты = ДокументПоставки.Контрагент;
                   Операция.Кредит.Материалы= ДокументПоставки.Материал;
                   Операция.Количество = ДокументПоставки.Количество;
                   Операция.Сумма = ДокументПоставки.Сумма;
                   Операция.СодержаниеПроводки = "Оплачено сырье";
                   Операция.НомерЖурнала = "УСН";
                  
                   Если ДокументПоставки.НДС>0 Тогда
                        Операция.НоваяПроводка();
                        Операция.Дебет.Счет = СчетПоКоду("У.03");
                        Операция.Кредит.Счет = СчетПоКоду("У.02");
                        Операция.Сумма = ДокументПоставки.НДС;
                        Операция.СодержаниеПроводки = "Списываем НДС";
                        Операция.НомерЖурнала = "УСН";
                        Операция.ПервичныйДокумент =Формат(ДокументПоставки.ДатаДокВходящий, "Д ДДММГГГГ")+", №"+ДокументПоставки.НомерДокВходящий;
                   КонецЕсли;
                  
             КонецЦикла;
             Операция.Записать();
            КонецЕсли;
            Док=СоздатьОбъект("Документ");
            Док.НайтиДокумент(ДокументПоставки);
            Док.ОплатаДок=1;
            Док.Записать();
            Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
             //Если ДокументПоставки.Итог("НДС")>0 Тогда

                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("У04");
                   Операция.СодержаниеПроводки="Отражен факт расхода";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=Сумма;                  
            // КонецЕсли;

            ИначеЕсли КоррСчет<>СчетПоКоду("51") Тогда
             Операция.НоваяПроводка();
             Операция.Дебет.Счет=СчетПоКоду("У04");
             Операция.СодержаниеПроводки="Отражен факт расхода";
             Операция.НомерЖурнала="НУ";      
             Операция.Сумма=Сумма;
            КонецЕсли;
            Если ДокументПоставки.Вид()="УслугиСтороннихОрганизаций" Тогда
             Если ДокументПоставки.Итог("НДС")>0 Тогда
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("НДС");
                   Операция.Дебет.Контрагенты=Субконто1;
                   Операция.Дебет.Договоры=Субконто2;
                   Операция.СодержаниеПроводки="НДС";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=ДокументПоставки.Итог("НДС");
             КонецЕсли;
            КонецЕсли;
       ИначеЕсли (КоррСчет<>СчетПоКоду("51")) И (КоррСчет<>СчетПоКоду("66.3")) И (КоррСчет<>СчетПоКоду("71.1")) Тогда
            Операция.НоваяПроводка();
            Операция.Дебет.Счет=СчетПоКоду("У04");
            Операция.СодержаниеПроводки="Отражен факт расхода";
            Операция.НомерЖурнала="НУ";      
            Операция.Сумма=Сумма;                  
       КонецЕсли;      
       Если УчитыватьДляНУ=1 Тогда
            //Если ДвижениеДенежныхСредств.Наименование="Оплата за основные средства" Тогда

            // Если КоррСчет=СчетПоКоду("60.1") Тогда

            //       Если ДокументПоставки.Выбран()=0 Тогда

            //            Предупреждение("Не выбран документ поставки");

            //            СтатусВозврата(0);

            //            Возврат;

            //       КонецЕсли;

            //       Если ДокументПоставки.КоличествоСтрок()>1 Тогда

            //            Предупреждение("В документе поставки должно быть поступление одного ОС");

            //            СтатусВозврата(0);

            //            Возврат;

            //       КонецЕсли;

            //       ОснСр=СоздатьОбъект("Справочник.ОсновныеСредства");

            //       ДокументПоставки.ВыбратьСтроки();

            //       ДокументПоставки.ПолучитьСтроку();            

            //       ОснСр.НайтиЭлемент(ДокументПоставки.ОбъектВнеоборотныхАктивов);

            //       ОснСр.Оплата.Установить(ДатаДок,Сумма);

            //       ОснСр.Записать();

            //       Операция.НоваяПроводка();

            //       Операция.Дебет.Счет=СчетПоКоду("У02.1");

            //      

            //       Операция.Дебет.ОсновныеСредства=ДокументПоставки.ОбъектВнеоборотныхАктивов;

            //       Операция.Дебет.ДатыОплаты=ДатаДок;

            //       Операция.СодержаниеПроводки="Учтена оплата основных средств";

            //       Операция.НомерЖурнала="НУ";      

            //       Операция.Сумма=Сумма;

            // КонецЕсли;

            //Иначе

             Если (КоррСчет=СчетПоКоду("60.1")) И (ДокументПоставки.Выбран()=1) Тогда
                   Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
                        Если ДокументПоставки.Итог("НДС")>0 Тогда
                         Операция.НоваяПроводка();
                         Операция.Дебет.Счет=СчетПоКоду("У02.2");
                         Операция.СодержаниеПроводки="Учтен расход: НДС по поступившему сырью";
                         Операция.НомерЖурнала="НУ";      
                         Операция.Сумма=ДокументПоставки.Итог("НДС");                  
                        КонецЕсли;
                   Иначе
                        Операция.НоваяПроводка();
                        Операция.Дебет.Счет=СчетПоКоду("У02.2");
                        Операция.СодержаниеПроводки="Учтен расход";
                        Операция.НомерЖурнала="НУ";      
                        Операция.Сумма=Сумма;
                   КонецЕсли;
             Иначе
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет=СчетПоКоду("У02.2");
                   Операция.СодержаниеПроводки="Учтен расход";
                   Операция.НомерЖурнала="НУ";      
                   Операция.Сумма=Сумма;
             КонецЕсли;
            //КонецЕсли;

       КонецЕсли;
КонецЦикла;
Операция.Записать();
КонецПроцедуры
//_____________________________________________________________________________

Процедура ОбработкаПроведения()
УСН();
ТипОтчета = Валюта.Выбран() + 1;
Сч19 = СчетПоКоду("19.3");

Если ДокументПоставки.Выбран()=1 Тогда
       Если ДокументПоставки.Вид()="ПоступлениеМатериалов" Тогда
            ДокументПоставки.ВыбратьСтроки();
            Пока ДокументПоставки.ПолучитьСтроку()=1 Цикл
             Операция.НоваяПроводка();
             Операция.Дебет.Счет = СчетПоКоду("У.05");
             Операция.Дебет.Контрагенты = ДокументПоставки.Контрагент;
             Операция.Дебет.Материалы= ДокументПоставки.Материал;
             Операция.Кредит.Счет = СчетПоКоду("У.01");
             Операция.Кредит.Контрагенты = ДокументПоставки.Контрагент;
             Операция.Кредит.Материалы= ДокументПоставки.Материал;
             Операция.Количество = ДокументПоставки.Количество;
             Операция.Сумма = ДокументПоставки.Сумма;
             Операция.СодержаниеПроводки = "Оплачено сырье";
             Операция.НомерЖурнала = "УСН";
            
             Если ДокументПоставки.НДС>0 Тогда
                   Операция.НоваяПроводка();
                   Операция.Дебет.Счет = СчетПоКоду("У.03");
                   Операция.Кредит.Счет = СчетПоКоду("У.02");
                   Операция.Сумма = ДокументПоставки.НДС;
                   Операция.СодержаниеПроводки = "Списываем НДС";
                   Операция.НомерЖурнала = "УСН";
                   Операция.ПервичныйДокумент =Формат(ДокументПоставки.ДатаДокВходящий, "Д ДДММГГГГ")+", №"+ДокументПоставки.НомерДокВходящий;
             КонецЕсли;
            
            КонецЦикла;
            Операция.Записать();
       КонецЕсли;
КонецЕсли;
Если ТипОтчета = 2 Тогда
            Сч71 = СчетПоКоду("71.11");

       КурсВал = Валюта.Курс.Получить(ДатаДок);
       Кратность = Валюта.Кратность.Получить(ДатаДок);
       Кратность = ?(Кратность=0,1,Кратность);

       глТаблицаСчетов.УдалитьСтроки();
       глТаблицаСчетов.НоваяСтрока();
       глТаблицаСчетов.Счет = Сч71;
       глТаблицаСчетов.Субконто1 = Сотрудник;
       глТаблицаСчетов.Субконто2 = """";
       глТаблицаСчетов.Субконто3 = """";
       глТаблицаСчетов.Валюта = Валюта;
       глПереоценкаСчетов(Контекст, глТаблицаСчетов);

Иначе
       Сч71 = СчетПоКоду("71.1");
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
       Если ПустоеЗначение(КоррСчет) = 1 Тогда
            ТекстСообщения = "В строке №" + НомерСтроки + " не указан корреспондирующий счет.";
            глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1);
            глНеПроводить(ТекущийДокумент());
            Возврат;
            
       ИначеЕсли КоррСчет.Валютный = 1 Тогда
            ТекстСообщения = "В строке №" + НомерСтроки + " корреспондирующий счет не может быть валютным.";
            глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1);
            глНеПроводить(ТекущийДокумент());
            Возврат;
       КонецЕсли;

       Операция.НоваяПроводка();
       Операция.НомерЖурнала = "БК";
       Операция.СодержаниеПроводки = КомуЗаЧто;
       Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
       Операция.Дебет.Счет = КоррСчет;
       Сообщить ("КоррСчет это: "+ КоррСчет);
       Операция.Дебет.Субконто(1,Субконто1);
       Операция.Дебет.Субконто(2,Субконто2);
       Операция.Дебет.Субконто(3,Субконто3);
       Операция.Кредит.Счет = Сч71;
       Операция.Кредит.Сотрудники = Сотрудник;

       Если НДС > 0 Тогда
            Если ТипОтчета = 1 Тогда
             Операция.Сумма = Сумма - НДС;
            Иначе
             Операция.Сумма = Окр(Сумма*КурсВал/Кратность,2,1) - Окр(НДС*КурсВал/Кратность,2,1);
            КонецЕсли;
       Иначе
            Если ТипОтчета = 1 Тогда
             Операция.Сумма = Сумма;
            Иначе
             Операция.Сумма = Окр(Сумма*КурсВал/Кратность,2,1);
            КонецЕсли;
       КонецЕсли;

       Если КоррСчет.Количественный = 1 Тогда
            Операция.Количество = Количество;
       КонецЕсли;

       Если ТипОтчета = 2 Тогда
            Операция.Валюта = Валюта;
            Операция.ВалСумма = Сумма - НДС;
       КонецЕсли;
      
       // Отражение операций в налоговом учете.

       ОбъектыАналитикиНУ = глСчетИАналитикаРасходовНУ(Контекст, КоррСчет, Субконто1, Субконто2, Субконто3);
      
       // Если опредлен налоговый счет, то необходимо

       // сформировать проводку для целей налогового учета.

       СчетНУ = ОбъектыАналитикиНУ.Получить("Счет");
       Если ПустоеЗначение(СчетНУ) = 0 Тогда
            СуммаРасходов = Операция.Сумма;
            
            Операция.НоваяПроводка();
            Операция.НомерЖурнала = "НУ";
            Операция.СодержаниеПроводки = КомуЗаЧто;
            Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
            Операция.Дебет.Счет = СчетНУ;
            Для СчетчикЦикла = 1 По СчетНУ.КоличествоСубконто() Цикл
             ИдентификаторСубконто = СчетНУ.ВидСубконто(СчетчикЦикла,,).Идентификатор();
             Операция.Дебет.Субконто(СчетчикЦикла, ОбъектыАналитикиНУ.Получить(ИдентификаторСубконто));
            КонецЦикла;
            
            Операция.Дебет.Субконто(ВидыСубконто.УсловияПоступленияИВыбытия, Перечисление.УсловияПоступленияИВыбытия.Другие);
            
            Операция.Сумма = СуммаРасходов;
            Если СчетНУ.Количественный = 1 Тогда
             Операция.Количество = Количество;
            КонецЕсли;
       КонецЕсли;
КонецЦикла;

Операция.Записать();

ТекстСообщения = "Сотруднику "+Сотрудник+" зачтена сумма, выданная под отчет.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);

ТекстСообщения = "Документ проведен.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);
глПриПроведении(ТекущийДокумент());

КонецПроцедуры"

 
Jetta
Пост №2
Речь, как я понимаю, про 1С:УСН? У меня этой конфы...
03.04.2010 23:09
 
 
Dissar
Пост №3
У меня такая же ошибка в общехозяйственной бухгалт...
09.04.2010 09:05
 
 
Jetta
Пост №4
Не знаю, как это может быть! Поискала указанную ст...
09.04.2010 10:32
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании авансовый платеж автозаполнение реквизитов Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безвозмездная передача имущества безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм взыскание налогов видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты возмещение расходов восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам вычет НДС вычет по НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественные налоги имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лекарственные препараты лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая задолженность налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговая ставка налоговое администрирование налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налоговый учет расходов налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязанности налогоплательщика обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность в фсс отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы передача имущества перенос убытков персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подача уведомления подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверки бизнеса продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандартный налоговый вычет стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность УКД универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов уплата НДС уплата сбора упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги