Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

В 7.7 не формируется 2-НДФЛ у сотрудников с детьми

pentanom
читатель
офлайн
Дата регистрации: 09.04.2014
Сообщений: 27
Пост №31
 
07.04.2016 22:06
Ответ на пост №29

USSR, Сравнивал тексты функций глСобратьДанныеДляНДФЛ2011 и глСобратьДанныеДляНДФЛ2016 . В последней это сообщение просто добавлено.
По-моему, оно ничего особенного в себе не несет.

Ответили: пост №32
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 587
Пост №32
 
07.04.2016 22:52
Ответ на пост №31

pentanom, да только на бухов это знаете как действует... все эти "страшные" сообщения.

VEKTOR_1C
читатель
офлайн
Дата регистрации: 07.04.2016
Сообщений: 8
Пост №33
 
08.04.2016 09:02

По поводу расчетов вы правы, у нас в базе немного сотрудников и при проверки все норм рассчиталось у тех сотрудников, у кого нет детей, опять же со слов бухгалтеров, в других случаях, и их немало, присутствуют проблемы. Капнул глубже, оказывается 1С выпустила это обновление еще в 611 релизе, причем с рядом ограничений, которые вы можете прочесть в дополнении к описанию, и спустя 5 релизов они так ничего и не изменяли и не дорабатывали, поэтому если мне придется полезть в эти расчеты по просьбе клиентов, то я вам отпишусь, т.к. сами понимаете, придется не только исправлять но и дорабатывать за 1С-ков.

FAV
читатель
офлайн
Дата регистрации: 18.06.2010
Сообщений: 32
Пост №34
 
08.04.2016 10:25
Ответ на пост №6

Итак,уважаемые сотрудники фирмы 1с,я так понимаю что форум построен и для общения с вами в том числе. Поэтому хотелось узнать информацию о сроках выпуска релиза,с устранением ошибок,допущенными сотрудниками вашей же компании.Ответ- в ближайшее время,я как пользователь ваших разработок и оплачивающий услуги по обслуживанию 1с-извините,НО БУДУ СЧИТАТЬ ОТПИСКОЙ .

Ответили: пост №35
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 587
Пост №35
 
08.04.2016 11:13
Ответ на пост №34

FAV, всё напрасно... У них политика партии такая, что по 7.7 сроков выпуска не давать. А тем более у них сейчас куча проблем со снеговиком, так что клюшками они будут заниматься в мае, это в лучшем случае... :\

Ответили: пост №36
Светлана
читатель
офлайн
Дата регистрации: 11.04.2016
Сообщений: 1
Пост №36
 
11.04.2016 12:32
Ответ на пост №35

USSR, В 614 релизе неправильно заполнен справочник ВидыВычетов: предел 350000 , а не 280000, коды на детей 114, 115, 116 для 2015г заполнить. Не заполнена ГруппаВычета. Зайти с конфиг-справ_ВидыВычетов-форма списка-основная-вставить реквизит ГруппаВычета и заполнить из списка перечислений: стандартные на детей(в польз.режиме).
Номера строк глов.модуля не совсем точные, извиняюсь!
Глоб.модуль
после цикла
// доход на нашем предприятии
Для СчСтрок = 1 По ВсегоСтрок Цикл
      КодДохода=СокрЛП(Доходы.ПолучитьЗначение(СчСтрок,1));
      Если Найти(",1210,2610,2740,3020,1010,1110,1120,4000,",","+КодДохода+",")=0 Тогда
       СовокупныйДоходДляВычетов = СовокупныйДоходДляВычетов + Доходы.ПолучитьЗначение(СчСтрок,Сч+1) - Доходы.ПолучитьЗначение(СчСтрок,Сч+14);
      КонецЕсли;
КонецЦикла;
после 32842 вставить
//***изменено!!!-начало
       Если Сч=1 Тогда
      СовокупныйДоходДляВычетовПоТекущийМесяц=СовокупныйДохо­дДляВычетов;
      ДоходТекущегоМесяцаДляВычетов=СовокупныйДоходДляВычето­в;
       Иначе
      ДоходТекущегоМесяцаДляВычетов=СовокупныйДоходДляВычето­в-СовокупныйДоходДляВычетовПоТекущийМесяц;
      СовокупныйДоходДляВычетовПоТекущийМесяц =СовокупныйДоходДляВычетов;
       КонецЕсли;

       Если ДоходТекущегоМесяцаДляВычетов>0 Тогда
      //предоставляем вычеты если в месяце есть доходы
       //***изменено!!!-конец
вставить после 32949 после КонецЦикла; // обхода вычетов сотра
      
//***изменено!!!-начало
Иначе
      //в месяце нет дохода, вычеты не представляются
КонецЕсли; //не предоставляем вычеты в месяце без доходов
      //***изменено!!!-конец
после 32962 исправление
//***изменено!!!
// ОписаниеВычета=СписокКодовВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента); было
      ОписаниеВычета=СписокВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента);

после 33156
//***изменено!!!
      ОписаниеВычета=СписокВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента);
// ОписаниеВычета=СписокКодовВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента);было

после 33187
      //***изменено!!!
      ОписаниеВычета=СписокВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента);
// ОписаниеВычета=СписокКодовВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента); было

после 33255
//***изменено!!!
      ОписаниеВычета=СписокВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента);
// ОписаниеВычета=СписокКодовВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента); было

Ответили: пост №37
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 587
Пост №37
 
11.04.2016 17:47
Ответ на пост №36

Светлана, спасибо Вам конечно. Но моим пока 2-НДФЛ не горит и если что, могут ручками поправить на 2-3 человек. Вот если бы Вы выложили исходник кода по заполнению 6-НДФЛ, мы бы вам стоя аплодировали :)

lev svinov
читатель
офлайн
Дата регистрации: 11.04.2016
Сообщений: 1
Пост №38
 
11.04.2016 18:50

попробуйте найти строчку в процедуре Глобального модуля:глСобратьВычетыНДФЛ2016
      ОписаниеВычета=СписокКодовВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента);
она находится находится, прям над строкой, которая выдает ошибку
надо заменить на
      ОписаниеВычета=СписокВычетовСотра.ПолучитьЗначение(СчВычетов,КодЭлемента);
таких строк несколько в этой процедурине,надо заменить все.
ЗЫ:В релизе УСН 259 не работает, тоже(в бухии 614, скорее всего, то же самое)
Открыл релиз 257, где все работало, и, там это увидел, собственно, оттуда, строчку и взял. Видимо, они задумали что - то сделать, но, не доделали...
А, надо было сотру распечатать 2НДФЛ срочно.
Думаю, поправят скоро всё это
ЗЫЗЫ Светлана написала то же самое, даже,более...
А, 6 НДФЛ... заготовка для заполнить есть, процедурина пустая. Надо разбираться как оно заполняется.
Если НЕ(фирма 1с выпустит апдейт) И (бухам будет заполнять влом) Тогда
//Будет алгоритм заполнения;
КонецЕсли;//))

Алексей_К
читатель
офлайн
Дата регистрации: 20.02.2008
Сообщений: 6
Пост №39
 
18.04.2016 16:49
Ответ на пост №21

pentanom,
в 614 релизе сумма налога исчисленная выводилась неправильная, эта же ошибка осталась и в 615 релизе. В глобальном модуле есть функция глСтавкаНалогаПоСтатусуНеРезидента(). Вот в этой функции все условия написаны наоборот. Во всех условиях этой функции нужно написать СтатусНеРезидента = 1

Ответили: пост №40
pentanom
читатель
офлайн
Дата регистрации: 09.04.2014
Сообщений: 27
Пост №40
 
18.04.2016 17:12
Ответ на пост №39

Алексей_К, это вы мое сообщение в ИнфоСтарт скопировали ?
Так то, что я написал туда относится к 7.70.260 (УСН), а в 7.70.615 (ОСНО) в этой части все в порядке.

Ответили: пост №41 , пост №42
Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Представление регламентированной отчетности
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги