Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Списание безналичных в УТ

Валерий Дедов
новичок
офлайн
Дата регистрации: 15.02.2020
Сообщений: 3
Пост №1
 
15.02.2020 08:52

При списании безналичных на основании заявок, подбор дает выбрать нужное количество заявок, но в назначение платежа падает только три, несмотря что выбрано большее количество. При настройки формы поле "Назначение платежа" увеличил, заполнение стоит авто..

Почему не падает больше трех? Косяк УТ или где то можно откорректировать?

Ответили: пост №4
Контрольное Cоотношение Равенство
активный пользователь
онлайн
Дата регистрации: 28.01.2018
Сообщений: 138
Пост №2
 
16.02.2020 12:15

Валерий Дедов пишет:

Цитата
При списании безналичных на основании заявок, подбор дает выбрать нужное количество заявок, но в назначение платежа падает только три, несмотря что выбрано большее количество. При настройки формы поле "Назначение платежа" увеличил, заполнение стоит авто.. Почему не падает больше трех? Косяк УТ или где то можно откорректировать?
Версия - какая?

Ответили: пост №3
Валерий Дедов
новичок
офлайн
Дата регистрации: 15.02.2020
Сообщений: 3
Пост №3
 
16.02.2020 18:41
Ответ на пост №2

Платформа 8.3.16.1063

УT 11.4.11.55

Валера Пупкин
новичок
офлайн
Дата регистрации: 18.02.2020
Сообщений: 11
Пост №4
 
19.02.2020 13:05
Ответ на пост №1

Валерий Дедов, так, значит длину реквизита НазначениеПлатежа (в типовой 210 символов) вы увеличили, верно? Тогда вам надо в общих модулях найти модуль ДенежныеСредстваСервер, в нём имеется функция НазначениеПлатежа, и в самом конце этой функции имеется участок кода, который проверяет, чтобы длина Назначенияплатежа не превысила 210 символов и обрезает лишнее.

Ответили: пост №5
Валерий Дедов
новичок
офлайн
Дата регистрации: 15.02.2020
Сообщений: 3
Пост №5
 
20.02.2020 10:46
Ответ на пост №4

Валера Пупкин,
все верно количество символов увеличил.. посмотрел участок кода (если это то?).. но не понятно как изменить количество символов, после которых обрезание?

Цитата
Цитата


ЗаполнитьТекстНазначенияПлатежа(Объект) Экспорт
      
      ТекстНазначение = "";
      
      Если ЗначениеЗаполнено(Объект.БанковскийСчетКонтрагента) Тогда
            ТекстНазначение = Справочники.БанковскиеСчетаКонтрагентов.ПолучитьРеквизитыБанковскогоСчета(
                  Объект.БанковскийСчетКонтрагента).ТекстНазначения;
      КонецЕсли;
      
      Если ТекстНазначение = "" Тогда
                  ТекстНазначение = НазначениеПлатежа(Объект);
      Иначе
            ТекстСумма = "Сумма " + Формат(Объект.СуммаДокумента, "ЧДЦ=2; ЧРД=-; ЧН=0-00; ЧГ=");
            ТекстСуммаНДС = ТекстСуммаНДСПлатежа(Объект.Валюта, Объект.РасшифровкаПлатежа, Истина);
            ТекстНазначение = ТекстНазначение + Символы.ПС + ТекстСумма + Символы.ПС + ТекстСуммаНДС;
      КонецЕсли;
      
      Объект.НазначениеПлатежа = ТекстНазначение;
      
КонецПроцедуры

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги