Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

1С: ТиС 7.70.998. Переход на НДС = 20%

USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 455
Пост №1
 
04.12.2018 13:24

Конечно, спасибо за столь рано выпущенный релиз по Торговле, НО
1) Добавлена обработка "ПомощникИзмененияСтавкиНДС "
      во-первых маленькое замечание:
      Вместо вот этого кода:
      
      Если ПустоеЗначение(ВыбТМЦ) = 0 Тогда
            Если ВыбТМЦ.ЭтоГруппа() = 1 Тогда
                  ТекстЗапроса=ТекстЗапроса+"
                  |Условие(Номенклатура.ПринадлежитГруппе(ВыбТМЦ) = 1);";
            Иначе
                  ТекстЗапроса=ТекстЗапроса+"
                  |Условие(Номенклатура = ВыбТМЦ);";
            КонецЕсли;      
      КонецЕсли;

      достаточно было написать в тексте запроса: |Условие(Номенклатура В ВыбТМЦ);
      ну это ладно, так как это никак не влияет на работу обработки.

      во-вторых, ведь есть прекрасная обработка в типовой конфигурации: Справочники -> Групповая обработка       справочников -> Номенклатуры. В которой можно задать фильтр по ставке НДС=18% (18/118) и потом исправить её       на 20% (20/120).
      Достаточно было описать алгоритм работы пользователя в начале 2019 года


2) Не обработаны места в конфигурации вида:
            Если ДокОснование.ДатаДок >= '01.01.2004' Тогда
                  СтавкаНДС = Перечисление.СтавкиНДС.НДС18_118;
            Иначе      
                  СтавкаНДС = Перечисление.СтавкиНДС.НДС20_120;
            КонецЕсли;
Может кому пригодится, условие нужно заменить на:
            Если ДокОснование.ДатаДок < '01.01.2019' Тогда
3) Нужна ещё обработка справочника "Пользователи", чтобы автоматически установить реквизит "Основная ставка НДС" = 20%. (так как может быть очень много пользователей в конфигурации)

Вообщем пока сыровато, может ещё что-то пропустили. Проверьте, пожалуйста...

Ответили: пост №2
Евгений Голосной
новичок
офлайн
Дата регистрации: 08.02.2019
Сообщений: 3
Пост №2
 
08.02.2019 16:26
Ответ на пост №1

USSR,Добрый день! Скажите, как можно обновить НДС на 20% без обновления базы?

Ответили: пост №3
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 455
Пост №3
 
08.02.2019 19:31
Ответ на пост №2

Евгений, смотря какая конфигурация. Если ТиС:
1) у каждого пользователя установить ставку пр умолчанию 20%
2) у всей номенклатуры, которая было 18, сделать 20. Смотрите выше описано как сделать без обновления типовыми методами.
В принцип всё. В печатных формах должно быть всё правильно, там не завтсит от того какая ставка.
Если не типовая или самописная конфигурация, то примерно также. Но ещё печатные формы придётся доработать. У 1С в типовой торговле редакции 9.2 универсально сделаны печатные формы.
Как то так...

Евгений Голосной
новичок
офлайн
Дата регистрации: 08.02.2019
Сообщений: 3
Пост №4
 
08.02.2019 19:59

Спасибо большое что откликнулись и за разъяснение! Попробую! Как я понял они там трусятся за то чтобы у них онлайн касса, которую прикрутили на неведомо сколько лет необновляемую 1С под откос не пошла. Кстате, второй магазин на УТ 11-й, которую тоже ни разу не обновляли и прикрутили кассу, которая ещё и РИБ. Схема примерно также, или её логичнее всё таки обновить?

Ответили: пост №5
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 455
Пост №5
 
09.02.2019 07:03
Ответ на пост №4

Евгений, не за что, на то он и форум. Если УТ под замком (типовая или мало настроек) я бы обновил.

Ответили: пост №6
Евгений Голосной
новичок
офлайн
Дата регистрации: 08.02.2019
Сообщений: 3
Пост №6
 
14.02.2019 21:46
Ответ на пост №5

USSR,Спасибо!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Представление регламентированной отчетности
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги